Zeichnung maßstabsgetreu in word exportieren

Margareta Hofmeister shared this question 1 week ago
Answered

Hallo,

ich bin ein blutiger Anfänger in GeoGebra (Version GeoGebra_6; 6.0.631). Heute habe ich es geschafft, eine Zeichnung in ebener Geometrie anzufertigen.

Könnt ihr mir bitte eine Schritt für Schritt Anleitung geben, wie ich nur meine Zeichnung maßstabsgetreu in ein Worddokument bekomme? Alle Versuche (Bild exportieren, Herunterladen als...) erzeugen den kompletten Bildausschnitt (also ein Bild mit viel weißem Rand) und nicht nur die Zeichnung. Folglich ist die Zeichnung nicht mehr maßstabsgetreu.

Ich habe auch schon im Forum gelesen, dass ich das in Word eingefügte Bild auf 100% setzen muss. Trotzdem erscheint eine 12 cm lang gezeichnete Strecke nur ca. 9 cm lang.


Vielen Dank schon mal für die Hilfe.

Comments (8)

photo
1

Ich verstehe gerade das Problem nicht ganz. Was hat denn ein weißer Rand damit zu tun, dass da was nicht maßstabsgetreu wird? Das hat doch nur Einfluss auf die Maße des entstehenden Bildes. Rand kann man z.B. vermeiden, indem man den Bildausschnitt in Geogebra gleich entsprechend anpasst (Größe des Fensters ändern und entsprechend zoomen), oder man beschneidet das Bild einfach hinterher (müsste sogar selbst innerhalb von Word gehen). Nichts davon ändert irgendwas an der Größe Deiner Konstruktion im Bild.


Wenn man in Geogebra als Bild exportiert, kann man da auch die Skalierung angeben, also festlegen wie lang eine Geogebra-Einheit dann im Bild wird. Wenn also Deine Strecke in Geogebra die Länge 12 hat und Du einstellst, dass eine Einheit einem Zentimeter im Bild entsprechen soll, dann hast Du im Bild (bei Originalgröße) auch eine 12cm lange Strecke. Bei mir (in Geogebra 5) klappt das ohne Probleme. Wenn man das Bild dann in Originalgröße in Word einfügt, sollten die Maße dort auf der Seite auch wieder passen.

photo
1

See here for how to crop etc https://wiki.geogebra.org/e...

photo
1

Es klappt leider nicht. Ich verstehe es selbst nicht.

1. Frage: Muss ich auf "Herunterladen als" drücken und dann als .png Datei?

2. Wenn ich das drücke, werde ich nicht nach der Skalierung gefragt.

3. Wenn ich das Bild in Word einfüge, erscheint es viel kleiner. Durch Rechtsklick auf das Bild und anschließend "Größe und Position" kann ich zwar auf 100% umstellen, aber trotzdem ist es nicht die Originalgröße.


Ich bin ratlos. Deshalb füge ich mal die Worddatei an, die bei mir entsteht.

Muss ich im GeoGebra Programm irgendwas umstellen oder kann es sein, dass ich im falschen Programm zeichne? Ganz am Anfang, wenn ich die Strecke zeichnen will, fragt mich das Programm nach einem Schieberegler. Ich habs schon mit und ohne Schieberegler versucht, aber immer das gleiche Problem.


Wie gesagt, ich bin ein blutiger Anfänger und scheitere leider schon bei den einfachsten Sachen.

photo
1

Hallo Margareta,


kein Grund zur Sorge.

Jetzt merkst Du, wie sich mancher Schüler bei Mathe fühlt.


Und was sagst Du dann? - Ich bin mir sicher, dass Dir ein paar aufmunternde Worte einfallen. :smile:


Du hast ja schon den Dialog zum Export von Bilder gefunden.

Wenn Du das aufrufst, dann wirst Du zu etwas hier geleitet:


4101671242ea6773249fea8b6633f43d


Versuch doch mal, ob es dann klappt, wenn Du das Verhältnis wie im Bild änderst.


Gruß

mire2


PS:

Oh toll - lese gerade, dass Du GeoGebra 6 nutzt.

Da finde ich diesen Dialog natürlich nicht, aber die Version nutze ich auch nie.

photo
1

Wie es aussieht, hat man in der Browser-Version wohl diese Auswahl gar nicht. Ich hab jetzt nicht ausprobiert, was da als Standard genommen wird, aber mit dem von Michael erwähnten ExportImage-Kommando hast Du alle Möglichkeiten. Einfach in Geogebra in der Eingabe z.B.

ExportImage("filename", "image.png", "scalecm", 2, "dpi", 600, "transparent", true)
eingeben. Dann öffnet sich ein Dialog zum Speichern, und zwar schon mit entsprechenden Einstellungen. Zur Bedeutung:
  • Der Parameter "filename" bedeutet, dass als nächster Parameter der Dateiname kommt. (Allerdings ist es gar nicht so wichtig, als nächsten Parameter anstatt "image.png" einen anderen Dateinamen auszuwählen, da Du den im Speichern-Dialog eh nochmal ändern kannst.
  • Der folgende Parameter "scalecm" bedeutet, dass als nachfolgender Parameter die Angabe zur Skalierung in cm kommt, also wieviel cm eine Geogebra-Einheit im Bild darstellen soll. Im Beispiel eine 1 für 1cm pro Geogebra-Einheit.
  • Der folgende Parameter "dpi" sagt dann noch, dass als nachfolgender Paremeter die Auflösung kommt. Im Beispiel 600 für 600 dpi (dots per inch = Punkte pro Zoll). Kanns Du einstellen, je nachdem wie gut die Auflösung sein soll. Für die meisten Dinge reicht vermutlich 300 dpi.
  • Der Parameter "transparent" sagt, dass als nächster Parameter angegeben wird, ob der Hintergrund transparent sein soll oder nicht. Kannst Du selber entscheiden, was da für Dich sinnvoller ist.
  • Man kann auch noch weitere Parameter nutzen, die aber für Deinen Fall erstmal nicht so wichtig sind, denke ich. Einfach mal den Link von Michael anklicken, da gibt es Erklärungen und Beispiele. Und Du kannst auch Parameter weg lassen, dann werden halt deren Standardeinstellungen genommen.

Und falls Du das mit dem Kommando nicht so magst, dann halt nicht über die Browser-Version machen, sondern von der lokal installierten App, da bekommt man das schon erwähnte Auswahlfenster, in dem man diese Einstellungen machen kann (siehe Screnshot von mire2).

photo
1

Ich hatte die Version "GeoGebra Classic 6" lokal an meinem PC und hiermit hat es einfach nicht funktioniert. Deshalb habe ich alles deinstalliert und mir die Version "GeoGebra Classic 5" runtergeladen.

Damit klappt es.

Vielen lieben Dank euch für die Hilfe!!!

photo
1

Voller Euphorie habe ich meine Zeichnung erstellt, aber es ist einfach nicht zu glauben:

Wenn ich die Graphik als Bild exportiere mit Koordinatengitter und mit x- und y-Achse und anschließend in Word einfüge, zeigt es mir das Bild in 47 % an. Ich stelle auf 100 % um und alles ist super.

Sobald ich allerdings die Koordinatengitter ausschalte und auch die Häkchen bei der x- und y-Achse wegnehme, zeigt es mir das in Word eingefügte Bild in 79 % an. Bei einer Umstellung auf 100 % passt es also nicht, sondern ist zu klein. Es ist wie verhext.

photo
1

Das hat mit Word zu tun - skaliert zu große Bilder.

Achte mal auf die Gesamtgröße des exportierten BIldes. Bei mire oben wird 11.98 cm x 5.98 cm bei 1336 x 796 px angegeben - das hängt ab von der Größe des Grafik-Fensters und vom Zoom. Wenn die Abmessungen das Format DIN A4 minus Ränder überschreitet muß Word die Bilder schrumpfen. Du hast in Word mit Standard-Rand ca. 16 cm in der Breite für das Bild. Machst DU mehr muß Word das Bild skalieren....

/B7RJqsqhx1ljAAAAAElFTkSuQmCC

An den TABs kannst Du sehen das es passt...

Wenn Du Wert auf Bildqualität legst solltest Du alle DPI nehmen, die Du kriegen kannst...

© 2021 International GeoGebra Institute