Why the CAS doesn't work like it should?

parthenocissus shared this question 1 week ago
Answered

Hi, I am trying to use Geogebra to do CAS calculations but the not even first thing I tried to solve with it worked out at all. I input this very simple equation: pi * r^2 = 30 and tried to solve what is r obviously. And I get a result that is completely useless and not what my study material says. It says the solution is 3,090 approximately. Geogebra just gives me r = sqrt30 * (sqrtpi / pi)

nothing else.

W... I'm doing wrong or is Geogebra just useless??

Comments (2)

photo
1

1. Be polite if you want a polite answer.

2 CAS makes symbolic calculations and keeps pi as a symbol. If you just want a mathematical result, just type r=sqrt(30/pi) in the input bar.

In fact you're not doing anything wrong, neither is GG useless nor does CAS doesn't work like it should. It's upon you to choose the way to handle GG. Sometimes it's nice to make calculations and to maintain the pi symbol in the result. Fine, choose CAS. If you want numbers, not symbols, choose the Input Bar and the Algebra View.

You don't complain that a bakery sells bread and a butcher sells meat, do you?

photo
1

Supplementary

In CAS you can make Symbolic [=] or Numeric [~] evaluation

and by Input key .... [alt enter] or [ctrl enter]

© 2020 International GeoGebra Institute