Webstart problem (Unable to Launch the Application)

Slumberland shared this question 7 years ago
Needs Answer

Hello,

GGB has lost file association (Windows XP.)


Happened on the update to 4.4. Spent some time with the old threads, but nothing has worked. Things I tried:


1. right-click on .ggb file, choose Java Web Start Launcher

(both the one in Program Files> Geogebra 4.4, or in Application Data....)

2. Delete Javascript cache

3. Uninstall and reinstall Geogebra

4. Delete the .ggb profiles using the Java utility

5. Uninstall Java, reinstall.

6. Uninstall Geogebra, reinstall.


Before 5. and 6., webstart gave no error: it flashed the Java splash screen, the quit. Uninstall/reinstall upgraded me to the error: "Unable to launch the application".

(Could not parse launch file; error at line 0.)


Double-clicking geogebra.jar correctly opens GGB, as does the icon in the start menu. I can still open files from within the app, etc.


HOWEVER. There is a wrinkle.

The Properties panel doesn't update consistently. Today, it stopped updating altogether. If I right click on an object to view its properties, then clicking on another object in the worksheet, the Algebra view or the Properties panel list selects the object,but continues to display the original object's name, definition and properties.

Usually, if I exit, nothing happens. Other times, the newly select object is redefined to the old text.


It's consistent. Updated to the latest version of GGB, uninstalled and reinstalled both Java and GGB, and greeted by exactly this behavior.


No other programs are misbehaving; no other part of GGB appears to be screwy, and the Properties panel updates correctly for the preferences. It only sticks when looking at individual objects in the construction.


...Any ideas?

© 2021 International GeoGebra Institute