Voronoi-Diagramm

Heinz shared this question 9 years ago
Answered

Hallo zusammen,


ich hab ein Voronoi-Diagramm angehängt. Wenn ich den Schieber a=30 einstelle, wird das Diagramm im linken Bereich falsch dargestellt. Bei a=60 tritt der Fehler nicht auf.

Kennt jemand eine Lösung?


Gruß Heinz


    GeoGebra 4.2.25.0 (15 March 2013)

    Java: 1.7.0_07

    OS: Windows 7

    Architecture: amd64

    Heap: 910MB

    CAS: MPReduce .016

    https://ggbm.at/561155

Comments (4)

photo
1

Ich hab jetzt mal a=10 und a=20 probiert und festgestellt, dass bei a=20 der Fehler nicht auftritt, aber bei a=10 tritt er auf.


Gruß Heinz

https://ggbm.at/561161

photo
1

Hallo Heinz


Ich kann den Fehler bestätigen.

Der Fehler tritt bei bestimmten Winkeln auf auf und wenn einer der Punkte im negativen Teil der xAchse ist.


https://ggbm.at/561167


Kennt jemand eine Lösung?

Hier eine Lösung, die nur für kreisförmig angeordnete Punkte gilt.


https://ggbm.at/561165


Es gibt noch einen deutschsprachigen Tread zum Thema Delaunay, Voronoi, Hüllkurve

https://www.geogebra.org/fo...


Und eine Bug-Meldung dazu im Bug-Forum

https://www.geogebra.org/fo...


Raymond

photo
1

Hallo Rami,


danke für den Workaround. Inzwischen hab ich mal noch eine Datei, die das selbe Problem bei quadratischen Diagrammen zeigt. Evtl. hilft das, den Fehler genauer zu untersuchen.


Beste Grüße


Heinz

https://ggbm.at/561207

photo
1

Hallo Heinz


Ich hab einen Bug-Report abgesetzt.

https://www.geogebra.org/fo...


Raymond

© 2022 International GeoGebra Institute