Two variable regression analysis - nothing happens

Mia Hauge Dolllerup shared this problem 5 years ago
Solved

When I select two columns of data in the spreadsheet, and choose "two variable regression analysis", the data appear in the dialog box, but when I choose Analyze, nothing happens.

The problem persists after 1) trying multiple times, 2) restarting Geogebra, 3) restarting my computer, 4) uninstalling and reinstalling geogebra.


Regression has worked for me with no problems earlier.


My system information:

GeoGebra 5.0.270.0-3D (26 August 2016)

Java: 1.7.0_40

OS: Windows 8

Architecture: x86 / x86

Comments (3)

photo
1

I am experiencing the exact same problem.


Workaround:

I couldn't find any way to fix it, but it is possible to perform a regression analysis in CAS. For instance, to fit a second degree polynomial you can run the following command:

FitPoly[{(1, 1), (2, 4), (3, 8)}, 2]


There is a similar function for each of the other regression models, which you can find here:

https://www.geogebra.org/ma...


Related Error Message?

I have attached some output from the GeoGebra log. There are a lot of STDERR's which I think might be related. It seems that GeoGebra is unable to find the input.

  1. DEBUG: org.geogebra.common.i.g.c.e.a[-1]: [DDMODEL] dataListSelected is null!


My system information

GeoGebra 5.0.270.0-3D (26 August 2016)

Java: 1.7.0_40

OS: Windows 7

Architecture: x86 / x86

photo
1

Hi. I am using 5.0.271 and everything is working again.


Thanks.

photo
1

Me too!

Thanks

© 2022 International GeoGebra Institute