Trying to GeoGebra on Linux and Raspberry Pi with Problems

Caleb Hawn shared this question 8 months ago
Answered

Hi! My science professor and I are trying to find a good graphing software to run on the Raspberry Pi B 1 that he has. In my science class, we create graphs to find the line of best fit. I was pleased to find that GeoGebra Classic 6 has a feature for that.

So I tried installing GeoGebra on Linux in many ways. I tried the Debian package (.deb file) that the GeoGebra website provides and tried installing it on a Xubuntu virtual machine, and tried installing it from the apt package manager using the command "sudo apt install geogebra" and "sudo apt install geogebra-classic." But none of these seemed to work. The closest I got was the splash screen opened, and then crashed, leaving behind a log file that I sadly don't know how to make sense of.

I also tried downloading the Raspberry Pi Debian package provided by the website, and also tried installing it using the apt command, on my Libre Computer (very similar to Raspberry Pi B 3). Still, no luck at actually opening the app.

I'm not sure what I'm doing wrong here. I'd love any help anyone can provide, as I'm still a noob at these things. Thanks, community!

P.S. Forgot to mention this. I emailed GeoGebra and they recommended trying the portable version of GeoGebra for Linux. I tried that as well, but nothing seemed to happen when I tried opening the executable file.

Comments (2)

photo
2

Please try the latest armhf .deb package from http://download.geogebra.org/installers/6.0/ or https://archive.raspberrypi....

photo
1

Thanks for your reply! I'll try installing the deb from the Raspberry Pi archive whenever I have time.

photo
© 2019 International GeoGebra Institute