The comand Cross in portuguese " ProdutoVetorial" don´t work

jorge geraldes shared this problem 6 years ago
Answered

Hi

The comands Cross in portuguese " ProdutoVetorial" and Dot "ProdutoEscalar" don´t work. Why?


Thank´s66545aa005387d5235582a6c400e17d7

f7b95bde9f7fffbb24ef69513aae8ba2

Comments (15)

photo
1

Try in the CAS View:

http://wiki.geogebra.org/en...


(or use * and ⊗)

photo
1

Hi


Thank´s


Jorge Geraldes

photo
1

As Jorge I have doubts regarding the working of Dot and Cross commands.

The question is: These commands should operate on input line?


I tried it in different languages ​​and in all of them observe that happens what I comment below

(version 4.9.318, working with WindowsXP)

---------

Dot and Cross (or their tanslations) do not appear in the list of All Commands.

-----------

Dot

Certaninly I've seen that the manual indicates that the command Dot "seems" as if it were only for the CAS... (and here it is working properly) but in the input line...


(1,2) * (3,4) or (1,2,3) * (4,3,-1) works properly


Dot[ (1,2),(3,4)] or Dot[(1,2,3),(4,5,6)] (command in english using translated version of GeoGebra) works properly


ProdutoEscalar[(1,2),(3,4)] in portuguese, ProducteEscalar[(1,2),(3,4)] in catalan, ProduitScalaire[(1,2),(3,4)] in French , etc. are classified like unknown command


However [size=85](and I do not think it's an anecdote but one aspect of the inner working of the program)[/size] if before I have run the command Dot translated (i.e ProdutoEscalar in portugueses, ProducteEsacalar in catalan...) in the CAS window ... then ProdutoEscalar, ProducteEScalar, etc. is also recognized, and works properly, in the input line (!!!)

-------------

Cross

In this case, the manual shows that the command applies in the input line and also for CAS (with the same sintax), but happens in detail exactly what I commented for Dot command.

photo
1

Hi Antoni


The commands ( cross and dot ) are still not translated... :cry:

Yes in CAS exists.....


Thank´s


Jorge Geraldes

photo
1

Are translated Dot and Cross commands?

Não, mas sim .... or perhaps .... Sim, mas não


Certaninly, DOt and Cross are not initially recognized (translated v4ersion of the command) in the input line...

but if you open CAS window and here use the command dot , translated, i. e. ProdutoEscalar after that ProdutoEscalar is already recognized and work in the input line.


So I ask:

exist or not exist the translation of the Dot and Cross commands to portuguese, catalan, etc ...

photo
1

Hi Antoni


Yes, the commands are translate but only work in CAS ( I don´t no why ....)


Thank´s


Jorge Geraldes

Portugal

photo
1

Hi,


I see that ProdutoEscalar and ProdutoVectorial not only work in CAS....


If you apply once ProdutoEscalar (or ProdutoVectorial) in CAS, ... after that ProdutoEscalar (or ProdutoVectorial) also works in input line.


And the symbols * for Dot and ⊗ for Cross also works properly at input line.


It is a very strange behavior!

photo
1

Hi


Yes it´s works after....CAS


Strange.....


Thank´s


Jorge Geraldes

photo
1

Although they don't appear in autocomplete, both commands work in the input bar.


However, the example in the manual for Dot Command

    Dot[{1, 3, 2}, {0, 3, -2}]

yields

5 in CAS and {0,9,-4} in the input bar.


Simon

photo
1

Hi


t is a very strange behavior!....


Thank´s


Jorge Geraldes

photo
1

About the post of Simon (slik)


Although they don't appear in autocomplete, both commands work in the input bar.


Certainly...in the input bar both commands works in english, but not translated. In the CAS view both commands works correctly, in english and also translated. Strange!!!

-------------

However, the example in the manual for Dot Command

Dot[{1, 3, 2}, {0, 3, -2}]

yields 5 in CAS and {0,9,-4} in the input bar.


Here I see an anomaly that must be put in clear by software developers.


The sintax indicates Dot[ <vector>, <vector>] but indeed in the input line

Dot[{1, 3, 2}, {0, 3, -2}]

corresponds to

Dot[ <list>, <list>]

and then I understand that what the command yelds is the list

{ Dot[1,0], Dot[3,3], Dot[2,-2] }

with the understanding that Dot[ <number>, <number>] yelds the produt of two numbers.


If in the input line you write effectively

Dot[ <vector>, <vector>]

i. e Dot[(1, 3, 2), (0, 3, -2)] then the command yelds, correctly, 5, like in the CAS view.


-------

However, the behavior seen in CAS view raises a question:


How to write the vectors in CAS view?

(1, -2.4) or {1, -2, 4}

---------

In the manual's page that explains the object "vector" there is some more detailed explanation on the subject (regarding the cross command and their application to lists)

photo
1

Hi,


it seems that to be able to use the (translated) CAS commands in in the input bar, you must enter at least one CAS command in CAS.

If you create a new file, show CAS and click on "Ajuda na Entrada" at the right of the input bar, you will not see "Commandos Especificos para CAS".

Enter e.g. Resto[3,2] (or any other CAS command in CAS), close Ajuda na Entrada, reopen it and you'll see "Commandos Especificos para CAS" in the list.

From then on you can use the (translated) CAS commands in the input bar, too.


If not, you can only use the english commands e.g. Cross[a,b] or Dot[a,b] where in the input bar

Cross[a,b] is replaced with a⊗b

and

Dot[a,b] is replaced with a b


This explains why in the input bar

    Dot[{1, 3, 2}, {0, 3, -2}]

gives {0,9,-4}

It's the same as entering

    {1, 3, 2} {0, 3, -2}

@Antoni:

In CAS there is no difference between a point and a vector.

    c:=(1,2,3)

results in (1,2,3) in CAS and a point c in Algebra.

    d:=Vetor[c]

results in (1,2,3)in CAS and a vector in Algebra.


To force CAS to create Vectors you must use Vector:

    n:=ProdutoVetorial[(2, -1, 3),(1,2,3)]

produces a point n (-9, -3, 5) and shows it in 3D View.

Whereas

    Vetor[ProdutoVetorial[(2, -1,3),(1,2,3)]]

produces and displays a vector.


Rather confusing.


Gerhard

photo
1

P.S.:


In Algebra (input bar)

Cross[a,b]

or

a ⊗ b

always generate a vector if a and b are vectors, which is correct, as the crossproduct always is a vector.

If a or b or both are points GGB generates a point which IMHO is nonsense.

The same is valid for a + b or a - b.

In CAS you always get points even for a + b or a - b unless you enclose them in Vector[...].


Not easy for students to understand why the crossproduct of two vectors is a point if your teaching Vector geometry with GGB.


Gerhard

photo
1

Thank you gno (Gerhard) for your detailes explanations.


However I still think that both in CAS and in Algebra, {1,2,3} is a list (although in some asspectes act as a vector in CAS).

And so the manual entry, Dot command, where it says,

Dot [<vector> <vector>]

and put

Dot [{1, 3, 2​​}, {0, 3, -2}] yields 5, the scalar product of {1, 3, 2} and {0, 3, -2}

I feel it would be more general to indicate vectors with ( ) and not with { } i.e

Dot [(1, 3, 2)​}, (0, 3, -2)]...


Similarly for the vector product (Cross command)

(from the manual... with { })

Cross[{1, 3, 2}, {0, 3, -2}] yields {-12, 2, 3}

If I follow your instructions, to have a vector I should put

Vector[Cross[{1, 3, 2}, {0, 3, -2}]]

and it yields ( (-12,0), (2,0), (3,0) )...


You can see "In my post I used (1,3,2) or (0,3,-2)". Certainly...ans so all works correctly... and in that is why also in this case it seems more appropriate to use () in manual entry to indicate vectors.

photo
1

Hi Antoni,


I must admit that I didn't try the example from the wiki in CAS, I used it in the "normal" input bar "Entrada" in portugês:

If you enter in Entrada

    Dot[{1, 3, 2}, {0, 3, -2}]

you get the list

lista1 = {0, 9, -4}

However CAS gives for the same entry

5 which is the scalar- or (inner product)

Entering

    Cross[{1, 3, 2}, {0, 3, -2}]

gives in Algebra and CAS a list

lista2 = {-12, 2, 3}


I think the wiki is made for Geogebra 4.0 (as is mentioned in the first help page) and there are no 3D Points or vectors.


If you enter in Entrada or in CAS

    Cross[(1, 3, 2), (0, 3, -2)]

you get a point

A = (-12, 2, 3)

which is the endpoint of the crossproduct vector.

Now if you enter

    Cross[Vector[(1, 3, 2)], Vector[(0, 3, -2)]]

in Entrada you get the correct Vector

a = (-12, 2, 3) (In Algebra View and 3D View it is displayed as a vector)

In CAS the same entry gives again the endpoint of the crossproduct vector (point in Algebra, also a point in 3D View)

To get CAS to produce a vector which is displayed as a vector in 3D View you MUST enter

    Vector[Cross[Vector[(1, 3, 2)], Vector[(0, 3, -2)]]]

Raher confusing (for the students, too).


Another confusing calculation:

Create a vector v in Algebra.

Then enter in CAS

    Vector[v]

and you get

((-12, 0), (2, 0), (3, 0))


I can only hope that some of the developpers have look at this thread.


Gerhard

© 2020 International GeoGebra Institute