Tableur/Statistiques - Histogramme vierge

Ordibilis shared this problem 2 years ago
New

Bonjour à tous,


Petite procédure pour répéter le bug :

1. Saisir des données en colonnes dans le tableur

2. Sélectionner une colonne de données du tableur

3. Outil "Statistiques à une variable" > "Données et effectifs"> Analyse (le diagramme en barres s'affiche)

3. Sélectionner une autre colonne de données du tableur

4. Outil "Statistiques à une variable" > "Classes et effectifs" > Analyse (l'histogramme ne s'affiche pas)


Remarque : si je choisis "Données brutes" à l'étape 2, l'histogramme apparait à l'étape 4, c'est donc apparemment le choix du type de données qui provoque le bug.

Comments (9)

photo
1

Please post your .ggb file

photo
1

Bonjour

Oulala je n'arrive à rien faire (GGb 5 v 518 sur Mac)

J'ai des bizarreries graphiques.

4b1f116a8a1499f0b4486155fa92e454

Je passe la souris au dessus de la colonne de gauche : les effectifs apparaissent... à gauche !

c499fba077da1cb7efa34784ffc4eac5

Pas grave, je clique sur la main : bref j'arrive à avoir mes données et mes effectifs. (avec mes effectifs à gauche !)

de5fd4aef17d8d6d0a777e4e5bbec102

Analyse > histogramme ok.

Même cinéma pour les classes et effectifs, mais quand j'ai enfin mis mes classes et mes effectifs, et bien, comme toi je n'ai pas d"histogramme

C"est effectivement pas normal...

@Michael : my file..!

Files: hist.ggb
photo
1

Bonjour,

Désolé pour la config, un oubli : GGb 5, v5.0.518, testé sous Win7 et 10.

See attached file (.GGb).


Et en vidéo : https://www.dropbox.com/s/l...


Merci d'avance,

photo
1

Les classes ne peuvent pas se régler ?

(dans ta vidéo et chez moi, c'est toujours 0-1 1-2 etc)

photo
1

Ah et bien, à force de recommencer, j'arrive enfin à voir l'histogramme tout le temps

Comme je ne l'avais jamais fait, je suppose que les choses se sont remises en place toutes seules (en faisant quoi ? mystère)

(mais j'ai toujours ces problèmes graphiques, et uniquement dans cette fenêtre (source des données)

et les classes ne peuvent toujours pas se régler. C'est normal..?)

photo
1

Si si, les classes se règlent avec "largeur".

En fait, l'apparition des histogrammes dépend du type de données que l'on fournit à l'étape 2 (voir la remarque du post initial).

Et les bugs d'affichage dans cette partie (tableur/stat) sont nombreux. Par exemple :

- l'affichage du polygone des effectifs n'est pas mis à jour une fois exporté dans la fenêtre graphique (il n'y a plus de lien entre la ligne brisée produite et les cellules du tableur, alors que c'est le cas pour le diagramme exporté)

- la table des effectifs apparait quand on coche la case dans les propriétés du graphique mais ne s'enlève pas quand on la décoche.

- si la taille des caractères est agrandie via l'option générale (menu Options), les paramètres statistiques calculés ne sont plus lisibles


- dans la partie Stat à deux variables, j'ai parfois des restes de résidus (c'est le cas de le dire) alors que je demande le nuage de points

- (le problème mentionné ici, qui est celui qui m'incommode le plus)

- (et certainement d'autres : c'est ceux qui me reviennent sur le moment)

photo
1

ok merci (et le "début" se règle avec "lancer" (drôle de traduction de "start" entre parenthèses...)

Je n'avais pas vu le "lancer" car, quelque soit la configuration, et même en plein écran, ma fenêtre de source des données est tronquée

0908964617fc0cbf32f4f4b45187e8c7

Il me faut à chaque fois agrandir la fenêtre pour voir le champ texte

Mais apparemment, vous n'avez pas ce problème graphique avec Windows...


- pour ton histogramme, dès fois il n'apparaît pas, dès fois il apparaît : ça dépend de l'ordre dans lequel on fait les manips

- d'accord pour le polygone des effectifs

- Pour la table des effectifs (dans les propriétés de l'histogramme), il faut fermer la fenêtre de ces propriétés (bouton options) pour la voir ou l'enlever

-pour la taille des caractères, si tu mets au max, rien n'est lisible nulle part (dans Graphique ou Algèbre ou..!)

- des trucs bizarres dans la fenêtre "Analyse de données". Dans la barre de styles, j"ai parfois un bouton 123/456, parfois impossible de le retrouver,

Finalement, tout ça est assez aléatoire lool

photo
1

Le module Statistiques est effectivement un bel exemple de variable aléatoire :D

photo
photo
1

Mêmes bugs graphiques dans la fenêtre "Source des données" que sur mon iMac 27" en 10.14, avec un MacBookPro 13" en 10.11

© 2021 International GeoGebra Institute