This object is in archive! 

Surface Pro: Can't find the name of Intel ICD OpenGL driver

Keith Harrison shared this question 3 years ago
Answered

Hi!


I'm receiving the error message "Can't find the name of Intel ICD OpenGL driver" on my new Surface Pro. There's a thread on this forum that points to a recent Intel graphics driver update (about August 14, 2017), but I tried that, and I got an error message saying that my machine's manufacturer didn't support that update. I went to the list of manufacturers provided, but Windows was not on the list (nor was Pegatron, the alleged manufacturer, according to Google).


Any suggestions?


Keith

Comments (5)

photo
1

You can try a manual installation of the drivers, since many manufacturers (like acer, too) prefer that users have their own drivers installed.

The procedure is explained here: https://www.intel.com/conte...

photo
1

I thought I should double check: It looks like my Surface Pro 4 has the most recent graphics driver available to it (Version 21.20.16.4627 released on July 20th). My machine has an Intel HD Graphics 520 adaptor.

What do you recommend? I've tried running GeoGebra with various compatibility settings, but with no luck.

photo
1

Intel drivers for 6th gen Hd 520 seem to be version 15.46.02.4729 released on July 11th.

The link given by Intel at the end of the troubleshooting procedure is this: https://downloadcenter.intel.com/download/26941

In my case they were installed properly (manual installation to override my laptop manufacturer restrictions) and GeoGebra worked just fine. Unfortunately Win10 automatically reverts the newly installed drivers with its own after a few minutes of use, and this is due to a policy of Windows itself :(

I pointed out this new issue to Intel, and they suggested the workaround explained here https://communities.intel.c...

photo
1

manual installation via setup.exe isn't possible for me - not on surface pro but on HP Spectre x360 - 13-ac002ng. The stup breaks with "this driver isn't vaidated by the manufactorer of your computer, please contact the manufactorer ..." (free translated from german ...)


BUT the way described here (s.u.: https://www.intel.com/conte...) by extracting the ZIP-version of the driver and selecting the *.inf-file (having disk method) worked well


thanks a lot Simona for your posting(s) above

© 2021 International GeoGebra Institute