Strange behaviour of ExportImage( ) command

Javier Cayetano Rodríguez shared this question 3 months ago
Answered

I am using the commmand ExportImage("type", "svg") to export the graphic view of an applet (https://www.geogebra.org/m/fxyhq9aq) If I try the command on the edit window, it works as it is supposed to do, offering the posibility of copying the image or downloading it (as shown on the first image).

Neverthless, when I am using the applet (thorugh the previous link) those options are not displayed any more (see the second screenshot).

I have checked this issue using on my Windows 10, on Chrome, Firefox and Edge browsers.


Is there anything I should include on the command to make it work properly?

Thank you


c238dae0f88645f80f5503f2d47bc115 (Screenshot of the applet working correctly, on the edit mode)


68a3728da530cad88a5c6dc7f54139e6 (Screenshot of the applet working strange, on the students view)


[*] The command is associated to a button:


2e88e833f2f6f2c57f963e243105dcd7

Best Answer
photo

Sorry, I see what you mean now. It's because it's loading a cut-down version of GeoGebra. You can make a 3D object eg

Dummy=(0,0,1)

to force the full version to load

Comments (4)

photo
1

Works fine for me - try clearing the browser's cache and/or use Chrome

photo
1

I have done so and even try on a different computer, but still got the same result. The button "download" does not appear nor the text indicating "right click to copy on the clipboard".

It is not that bad, but it is strange.

Thank you anyway.

photo
1

Sorry, I see what you mean now. It's because it's loading a cut-down version of GeoGebra. You can make a 3D object eg

Dummy=(0,0,1)

to force the full version to load

photo
1

f6acc44a8e0764f33077bab0b48e8507

Great! It works


Thank you :-)f6acc44a8e0764f33077bab0b48e8507

photo
© 2020 International GeoGebra Institute