Récupérer le code HTML

LPH shared this question 6 years ago
Answered

Bonjour,

Y a-t-il un équivalent à la commande CTRL+SHIFT+M des versions 2D antérieures pour récupérer le code HTML d'une figure créée avec ggb 5 ?
Dans la version ggb5, on peut maintenant récupérer uniquement le code ggbBase64 par Ctrl+Shift+B !


En effet, il est très surprenant d’avoir complètement supprimé en ggb5 la commande Ctrl+Shift+M qui donnait le code html en Java. Pourquoi ne pas proposer le code Html5 complet par Ctrl+Shift+M, au lieu de le supprimer complètement ?


Bref, cela ajoute un peu à la fracture avec ceux qui ne savent pas faire du développement Html5… c’est peut-être le but du jeu.


Bye, :wink:

Phil

Comments (6)

photo
1

Bonsoir,

Et quand je demande la lecture par mes navigateurs... rien. A part le titre de niveau h1 : html basic file
J’ai testé, normalement ça marche.

Ton problème doit sûrement venir de l’adresse relative : d’après ton chemin, ton fichier doit être placé juste avant le répertoire « GgbW ».


Bye,

Phil

photo
1

Bonjour,

Par contre, le résultat, c'est du grand n'importe quoi... les changements que commandent mes curseurs ne sont pas ceux qui se produisent dans mon .ggb
En effet, ça bogue sévèrement en html5 ! :anguished:

Il faudrait que tu télécharges ton fichier sur le tube et voir si ça fait la même chose en html5. Et dans ce cas, tu pourras signaler le bug et les spécialistes du code 3D pourraient d’aider. :confused:


Je situe le bug au niveau de l’utilisation de la commande :

Rotation[ <Objet>, <Angle>, <Point sur Axe>, <Direction ou Plan d'Axe> ]

C’est une rotation 3D que tu utilises avec des points 2D… peut-être que ce n’est pas prévu… à vérifier. :confused:

Pour le développement de la surface latérale, je n’ai pas encore trouvé. :(


Bye, :wink:

Phil

photo
1

Bonjour,

Par contre, le résultat, c'est du grand n'importe quoi...
J’ai essayé de mon côté, mais je n’ai pas rencontré de difficultés (voir ci-dessous) :

http://www.geogebratube.org...

Donc il n’y a pas de bug logiciel, mais plutôt ce que je pensais : une des commandes 3D qui est mal utilisée (sûrement la commande Rotation[]).

Je te laisse regarder comment j’ai procédé.


Bye,

Phil

photo
1

Bonjour à tous!


Je tente de reproduire ce qu'à fait cigale973 mais sans succès pour l'instant. Je pense qu'il s'ait d'un problème de place du fichier ggb par rapport à ggbW/web3d/... Concrêtement,où doit-on placer ce fichier ggb? Doit-il porter un nom particulier?


Merci beaucoup pour votre aide!

photo
1

Bonsoir mathos38,

Je tente de reproduire ce qu'à fait cigale973 mais sans succès pour l'instant. Je pense qu'il s'ait d'un problème de place du fichier ggb par rapport à ggbW/web3d/... Concrêtement,où doit-on placer ce fichier ggb? Doit-il porter un nom particulier?
En fait, si tu souhaites faire comme cigale973, tu dois d’abord créer un fichier html5…

Et c’est là que les choses se compliquent…

Le plus simple étant de poster ton fichier sur GeoGebraTube… et tu n’as rien à faire : tout est automatique.


La question posée par cigale973 (rebaptisé maintenant cigale973-2) concerne une démarche un peu technique qui est de créer soi-même son fichier html5 pour travailler hors-ligne. Maintenant, tout dépend du sens de ta démarche et de ta maîtrise technique. Il y a un petit protocole à suivre (voir la vidéo). Quand tu en seras là, fait moi signe à nouveau.


Cordialement,

Phil

photo
1

Merci bcp pour ton aide LPH! En fait, le problème était tout simple. Mon dossier ggbw s'était bizarrement lors de l'extraction nommé ggbw.0. le ".0" n'était pas visible sous mac mais il l'était sous windows. Tout fonctionne maintenant!


Merci encore!

© 2020 International GeoGebra Institute