Problema di connessione?

ilic.ferretti shared this question 6 years ago
Answered

Buongiorno a tutti,

innanzitutto GRAZIE del lavoro meraviglioso. Ho prodotto alcuni file *.ggb ed un geogebra book e li sto caricando, ma ho un problema.


Ho creato un file dinamico, ma quando lo carico su geogebra tube (DAL SITO, perché da Geogebra mi è impossibile farlo - vedi sotto) viene visualizzato tutto il contenuto in modo statico. ho sbagliato qualcosa o non è possibile avere presentazioni dinamiche sul sito?


Ho cercato di esportare il file in locale per dargli almeno un'occhiata, ma:

1) In Geogebra 5 l'esportazione è stata eliminata (ho letto che è stata una scelta, ok) e quindi si apre una finestrella in cui si annuncia che si sta preparando il caricamento, ma poi la finestrella si chiude e tutto tace... :cry:

. l'opzione "Apri da geogebra tube" apparentemente sembra funzionare, ma mostra sempre e solo un file (mentre nel frattempo ne ho caricati altri) e quando cerco di aprirlo NON si apre.

- Qualsiasi tentativo di accedere ai materiali online da Geogebra (forum, manuale...) fa apparire la clessidra ma poi si risolve in un nulla di fatto.


Mi sembra di capire che vi sia un problema di connessione tra Geogebra 5 e la rete; ho cercato delle eventuali opzioni di connessione (proxy? sicurezza?), ma non le ho trovate.


Sono riuscito a disconnettermi cliccando sul mio username in alto a destra (se posso permettermi: è molto POCO visibile ed intuitivo. Una voce regolare da menù sarebbe più facile da trovare) e si disconnette e riconnette regolarmente, ma continuano ad esserci i problemi di cui sopra.


2) In alternativa in Geogebra 4 (che ho in versione portable) mi crea un file, ma poi non riesco a visualizzarlo per impostazioni di sicurezza... di Java? Una finestra (anonima) mi avvisa che le impostazioni di sicurezza hanno bloccato l'esecuzione di un'applet "non protetta". Ho provato a cambiare le impostazioni di Java ma non mi ci muovo agilmente, e soprattutto vorrei poter dare indicazioni sicure ai miei studenti. L'ottimale sarebbe evitarlo (usando HTML5 e/o ridirigendoli su GeogebraTube immagino). Ho eseguito l'autotest su Java come consigliato sul wiki e risulta tutto ok.


Spero di non aver fatto domande inopportune: ho cercato su manuali e forum ma non sono riuscito a trovare indicazioni o casi simili al mio.

Mio sistema operativo: Win7


Grazie mille

Ilic


p.s. il mio foglio dinamico, che per ora è molto statico :flushed:, è qui: https://www.geogebra.org/st...

Comments (3)

photo
1

Il fatto che dici che avevi problemi sul sito in generale (clessidra "impallata") mi lascia pensare che hai fatto il caricamento in un momento in cui i server stavano facendo aggiornamento o manutenzione.

In effetti anche il tuo file non è scaricabile come .ggb, ma solo come .zip offline, e mancano tutte le altre opzioni di download - altra indicazione che mi fa ritornare al dubbio di cui sopra.

Tra l'altro ho caricato due file di test miei, sia da GeoGebra, che dal sito, con le tue stesse modalità di "condiviso tramite collegamento" e non ho riscontrato problemi.


In generale, per caricare su GeoGebraTube da GeoGebra devi utilizzare File->Condividi


Relativamente al tuo file, ti consiglio di eliminarlo e ricaricarlo su ggbtube dalla versione 5 o dall'ultima 4.4.

Eventualmente, se hai bisogno di ulteriore supporto, e il file non è dinamico come vorresti, allega qui il file e spiega cosa non funziona, così possiamo dargli un'occhiata.

A prima vista ti consiglierei di vincolare i due punti del segmento alle rette orizzontale e verticale, perchè se li trascini con il mouse tutta la costruzione va a pallino, in quanto il triangolo visualizzato non è più rettangolo.

photo
1

Grazie della risposta rapida.


Sui problemi di connessione dal software sono abbastanza perplesso, dato che allo stesso sito accedo tranquillamente con qualsiasi browser. Ho verificato che qualsiasi link installato dal programma (come quelli che compaiono nei menù dei programmi di windows relativi a Geogebratube ed al forum) non funzionano. Ho controllato le proprietà ed ho notato che il link a tube non è tube.geogebra.org ma http://www.geogebratube.org, ma anche quest'ultimo inserito in un browser funziona... :question: :?


In più posso dire che occasionalmente cercando di connettermi tramite il programma appare un messaggio che parla di errore di connessione e cita un codice 500. Non so se può essere utile per capire dove è il problema.


Problema risolto invece per la presentazione dinamica. Non so cosa sia successo, ma ho seguito il consiglio di ancorare i punti A e B (grazie!) e ne ho approfittato per migliorare altri dettagli. Quando ho ricaricato l'applet (sempre dal sito) magicamente si è presentata come dinamica! :D


http://tube.geogebra.org/bo...


Segnalo due piccoli difetti (probabilmente il posto dove indicarli è altrove: mi scuso, col tempo mi orienterò nel forum...)

1) Quando si sostituisce un applet il sito non accetta di caricare un applet che abbia lo stesso nome di quello attuale. Non avverte neppure, semplicemente non fa niente.


2) Nell'applet avevo messo un testo latex che non mi compariva. Ho rimosso una doppia specifica (tipo \darkgreen\bold{x_A}} ed il testo è comparso.


Grazie di tutto, se scoprirò altri dettagli sul mio problema di connessione li comunicherò. Se c'é qualche consiglio in proposito...

Ilic

photo
1

Domani mi guarderò i link di cui parli. Suppongo tu intenda quelli visualizzati alla voce "GeoGebra" nell'elenco "Tutti i programmi" di Windows. Ora proprio non ce la posso fare a riaccendere il pc :smiley_cat:

Per quanto riguarda il LaTeX nelle app - ohimė - solo un set di comandi LaTeX è supportato da Html5. Ti consiglio di dare un occhio qui http://forum.geogebra.org/v...

Per qualche suggerimento, e di verificare se i tuoi testi funzionano aprendo il file con la versione web.

© 2021 International GeoGebra Institute