Problem with moodle-qtype-plugin is not solved!

Martin Putzlocher shared this problem 4 months ago
New

The problem reported 3 weeks ago has been marked solved, but it actually is not.


In a moodle-platform, I'm working with (lernplattform.mebis.bayern.de), we've got 1M+ users in 500k+ courses, so this issue is affecting a lot of people.

Comments (13)

photo
1

Hello,

I confirm. Problem is not solved and very hassle !

If someone can do something…

photo
2

For testing, please can you try the following:

1) Install https://chrome.google.com/webstore/detail/requestly-redirect-url-mo/mdnleldcmiljblolnjhpnblkcekpdkpa?hl=en as a Chrome Extension

2) Configure it to replace

https://cdn.geogebra.org/ap...

with

https://test.geogebra.org/~...


and let us know if that helps.

photo
1

Hello Michael,

Thanks for trying to help us.

I just tested the patch but I still have the problem… Sorry

Isn't it possible switch back to the previous version without the bug ?

Regards

photo
1

Hi Michael,

In case you missed it: the qtype-plugin still doesn't work.


Did you find out, what's causing the missing/hidden display of moodle questions of geogebra type?

It would be kind, if anyone could answer to those who are raising their questions on https://moodle.org/plugins/... .

Is a rollback to a plugin-version prior to June 18th possible?

Regards,

Martin.

photo
3

Hi,

I've been fiddling around with the source code of the plugin myself and found out the reason of the display errors: The question text is hidden by a statement in renderer.php. To make the question text appear, line 93 of renderer.php can be changed to

$result .= html_writer::tag('div', $questiontext, array('class' => 'qtext;'));


The applet is not being displayed because the div with class ggb_preview is stacked above it: The z-index style option is to high (value of 90). This is causing the white background being stacked above the preview picture being stacked above the acutal applet. Setting the z-index manually to 0 during runtime works. Till now I haven't found out how to change the z-index of ggb_preview persistently from within the moodle-plugin. Is this possible at all?


Regards,

Martin.

photo
1

Thanks Martin, this helped me too :-)

photo
1

Hi Martin,

The text is back for me too. Great job !

A part of the problem is solved… Sorry I can't help for the rest…

Frederic

photo
1

Solve my problem here:

https://help.geogebra.org/t...

photo
1

Hi Michael and everyone,

It seems to me like Frederic hasn't got it fully solved for his platform. For me and my moodle platforms: There is still no solution.


Have you found a feasible and durable solution for the moodle-qtype problem?

If so, it would be necessary to upload a new plugin version to https://moodle.org/plugins/... . So that the 1051 moodle installations using the plugin can upgrade.

On github there was no change in code for four months now. Did you forget about this problem?


Regards,

Martin.

photo
photo
2

Hello Michael,

I just tested the qtype-Plugin as you described.

Still all elements of the question remain hidden. So, sorry, the changes you made didn't help yet.

Kind regards,

Martin.

photo
1

But at least the require.js-error is gone!

photo
1

I can also confirm the my Moodle error: "caught Error: Mismatched anonymous define() module: function(){return GGBApplet}" is solved, after using: https://test.geogebra.org/~...

photo
1

Thanks Michael for your hint. And in deed, the applet is loading but not displayed.


Looking after the properties for elements in the applet using the dev-tools of the browser, I always get an Exception: TypeError: Illegal invocation at Element.invokeGetter (<anonymous>:2:14).


Maybe this is an further hint.

photo
© 2019 International GeoGebra Institute