Problem in opening local ggb files with GeoGebra v.6

Γρηγόριος Κυριακού shared this problem 3 years ago
Solved

I have recently installed GeoGebra v.6. It's impossible to open my ggb files (older created with v.5, but even recent created with v.6) by double clicking. The only way I found is by drag-and-dropping the file into the window of GeoGebra v.6.

Has anybody else faced this problem?

Is there any solution, please?

Comments (16)

photo
1

click in menu (three horizontal segments) ->open then at rigth there are two icons: GGtube and folder

cilck on folder

photo
1

My problem is not that I don't know thw method: my problem is that files CAN'T BE OPENED IN ANY WAY.

Besides, I would like to open them by double clicking (without previous starting the application). And this also is impossible.

photo
1

I hav the same Problem. Older Files cannot be opened in any way. There`s only a white area, and any Tool does`nt work.

photo
1

I can confirm this. Only thing that seem to work is to open another file!

photo
photo
1

Same problem. Can any files be opened? I was just mentioning that Geogebra was relatively bug-free compared to some other math software, but it looks like I was mistaken wink

I tried it with a newer file from 2017 but still no luck so I guess it's not a old-file disparity. Has this worked before so it's an update problem?

However, if you unzip the file you can open the html in a local browser. It's all online of course (until it isn't), but I like to save downloaded stuff into categories or it gets out of hand.

photo
1

I don't see my comment. Do they have to be approved or something?

photo
1

I'm afraid opening local files by double click won't come anytime soon.


The bug where some files would not result in white screen even through File > Open is hopefully fixed for the next release (will be rolled out next week).

photo
1

Well, let's wait for the next release.

photo
1

I tried version 6.0.355.

There is an approvement: the menu works for every ggb file! [See response above by mathmagic: Click in menu (three horizontal segments) -> File -> Open. Then at rigth there are two icons: GGtube and folder. Cilck on folder].

But opening by double-clicking on ggb files doesn't work yet!

photo
1

Not by me. Still just opening as a blank screen.

photo
1

Me too. I cannot open .ggb files. using the folder option or with a double click

photo
1

I found that geogebra 6 saves .ggb files on my PC without the .ggb extension. These don't seem to reload. However, if I change the file name by adding the .ggb extension, geogebra seems to load it correctly.

photo
1

same issue, a year later. Bye bye version 6. Going back to v.5!

(I am an enthusiastic lover of ggb, I hate to see regression in newer versions :-(

photo
1

Now automatic file association (when both versions are installed) is with Version 6. Anyway you can still have both versions working, and change ggb file association to v.5. It works fine. I currently have it set this way

photo
1

To save a file in v.6 select the Download as... option in the burger menu, then either enter a new file name or just press Enter in the appearing dialog window. A file explorer windows open, where you can browse and select the destination folder and enter a file name.

photo
1

First open geogebra classic 6. Then on the right corner you see three lines. On click it shows file ,open etc. Just Click open On the right hand side there will be only one folder shown.Open that and from there choose your geogebra file created in Classic 5 or previous version.See the attached screen shot

photo
© 2020 International GeoGebra Institute