Problème de scrolling avec chrome

herve shared this question 3 months ago
Answered

Bonjour

J'utilise depuis 5 ou 6 ans des fichiers html sur mon site JeuGebra sans utiliser le passage obligé par GeoGebraTube, de manière que mon site soit utilisable en ligne et hors ligne sans avoir à modifier le code html. Pour cela, j'utilise GeoGebraWeb, j'appelle un fichier nommé nocache.js, qui se trouve le dossier web de GeoGebraWeb, que j'ai mis au bon endroit sur mon site : je n'utilise pas le code fourni actuellement par les fichiers hors ligne, parce qu'il est beaucoup plus lourd et plein de trucs qui ne me servent à rien, donc j'utilise l'ancien code d'il y a quelques années, qui me donnait toute satisfaction...

Depuis quelque temps, il se produit avec les navigateurs chrome et opera un truc bizarre : si j'ai mis un titre en balise dans mon fichier html, tout clic sur l'applet GeoGebra provoque un scrolling de la figure vers le bas (on ne voit plus le titre, mais ce n'est pas grave), mais surtout, la souris ne suit pas ce scrolling (résultat, il faut cliquer au-dessus de là où on vise...). Si on se replace avec l'ascenseur en début de fichier, le clic de souris revient au bon endroit (exemple avec ce lien).


Si on ne met pas de titre, évidemment, plus de problème (voir lien).

Avec Firefox, pas de pb.

J'ai remis à jour le dernier dossier web de GeoGebraWeb obtenu en téléchargeant une version hors ligne dans GeoGebraTube, le problème demeure.

Quelqu'un a-t-il déjà eu ce problème ou a-t-il une explication à me fournir ?

Hervé

Comments (8)

photo
1

Sorry, I can't see a problem in Chrome with the two links you have posted. What isn't working?


http://herve.chastand.free....

http://herve.chastand.free....

photo
1

Hi Michael

On my computer (and others I tested before), with chrome and opera (maybee androïd, I didn't test it, but an user told to me a problem of data enty recently), when I click for the first time on a domino, the title (between html tags h2) desappears (scrolling back), so if I click for the second time on an other domino, it does'nt work : I have to click on the place of domino before the scrolling. If I use the scrollbar positioning the applet with the title, it works fine after. My OS is Win8, Chrome is 76.0.3809.132 version (64 bits).


This problem occured recently, it works fine with Firefox, IE and Edge. Is it a bug in the html tag's interpretation of"h2" ?


Maybee you'll understand better with this file.

Regards, and thank you for your help...


Herve

photo
photo
1

Hi Michael

I try to describe my problem with five screenshots (mouse as red arrow...).


Initial view, with mouse on the green point 00


61d4701b4d40b49bf8388685336009dbview 2, after click on the green point : scrolling of the applet

87d28c6e20772c40cb4cb610fd0fd2f8


View 3 : the mouse works on top of the square (its space after scrolling)...d6345272baab2e7871b8958071446f02


View 4 : scrolling to the top with the scrollbar (the mouse comes back to the right place)


b2a2ef615adf71ab185e1eb1cc8102d3View 5 : all works fine now...

2d6c2a5f21c3db667705962726b26b57Best regards

Herve

photo
1

Hi Michael

I try to describe my problem with five screenshots (mouse as red arrow...).


Initial view, with mouse on the green point 00


61d4701b4d40b49bf8388685336009dbview 2, after click on the green point : scrolling of the applet

87d28c6e20772c40cb4cb610fd0fd2f8


View 3 : the mouse works on top of the square (its space after scrolling)...d6345272baab2e7871b8958071446f02


View 4 : scrolling to the top with the scrollbar (the mouse comes back to the right place)


b2a2ef615adf71ab185e1eb1cc8102d3View 5 : all works fine now...

2d6c2a5f21c3db667705962726b26b57Best regards

Herve

photo
1

Hi

No answer ? I add that it works fine offline with Chrome, it does'nt work online with the same GeoGebraWeb configuration...

Best regards

Herve

photo
1

Bonjour Herve,

I'm sorry but it seems that the two links that you added in your first post work fine from here.

Have you tried deleting the cache of Chrome?

photo
1

Buon Giorno Simona

Thank's a lot for your answer ! I deleted the cache of Chrome, and all is OK now (there is a scrolling, but I don't loose the mouse !!!). But what happened ? Is't an update problem ?


Ciao

Herve

photo
1

Sometimes, when GeoGebra materials platform is updated, some old setting stay in the cache of your browser.

Deleting the cache fixes this ;)

Happy new week, Herve!

photo
© 2019 International GeoGebra Institute