Problème de chargement d'objets avec attribut "Condition pour afficher l'objet""

CSP shared this problem 5 months ago
In Progress

Bonjour,

Je vous joins un fichier pour lequel l'attribut "Condition pour afficher l'objet" n'est plus accessible dans l'onglet "Avancé" sous GeoGebra 5 (version 5.0.627.0-d , mise à jour automatiquement, du 2 février 2021, sous Windows 10, Java 1.8.0_161-32bit).

En particulier, les objets texte correspondants ne s'affichent plus lorsque je clique sur le bouton "Correction" qui est sensé les faire s'afficher.

Par curiosité, j'ai réussi à ouvrir et faire fonctionner le fichier dans ma version de GeoGebra 6 (que je n'utilise pas pour les cours car notre établissement est encore sous version 5). Le problème avec GeoGebra 6, c'est que je ne peux plus faire de copie du graphique en copier/coller d'une sélection sous format vectoriel ce qui donne des images bitmap "baveuses" ; c'est une vraie régression par rapport à G5 dont la qualité des images copiées est excellente.

J'aurais tendance à penser qu'il s'agit d'un bug de G5 dans sa version récente car ce fichier fonctionne très bien depuis que je l'ai conçu depuis quelques mois (dernière modif du 28/01... avant la dernière maj de G5). Malheureusement, je ne peux plus le faire évoluer pour le moment.

Merci d'avance de votre aide.

Comments (7)

photo
1

Bonjour,


pour moi, c'est confirmé, l'onglet "Avancé" est bien fonctionnel en 625 et ne l'est plus en 627 (un bug de plus, avec celui de Max(liste)


j'espère pour toi que cela sera bientôt corrigé et qu'une nouvelle version sera mise en ligne.

photo
1

Bonjour,

J'ai en effet constaté un bug avec Max(liste) et je suis heureux que vous le confirmiez.

Aussi je remplace désormais la fonction Max(liste) par Elément(Derniers(Trier(liste)), 1) ... et ça marche.

Bonne journée à vous

photo
1

Bonjour,

Merci pour votre réactivité.

Si j'ai bien compris (ci-dessous) que cela serait corrigé dans la v629, est-ce que cela le sera aussi dans la version 5 ?

Bonne journée.

photo
1

629 est le futur numéro de version (aussi pour GGb5) actuellement celle qui pose problème est la 5.0.627

photo
photo
1

Thanks, it's working in v629 (very soon)

photo
1

If you're in a hurry you can try http://test.geogebra.org/~m...

photo
1

Thank you very much, it works fine (as far as my problem is concerned).

photo
© 2021 International GeoGebra Institute