Problème avec les traits visibles/invisibles en 3D

Ordibilis shared this question 2 years ago
Answered

Bonsoir,


J'ai un problème d'affichage de traits dans mes solides 3D.

Un dessin valant mieux qu'un long discours :

Cas 1 (OK) : traits cachés invisibles : les traits visibles sont pleins.

Cas 2 (NOK) : traits cachés en pointillés : TOUS les traits sont en pointillés.

Testé sous 5.0.399. En V6, on dirait qu'il y a une superposition des traits pleins et pointillés.

Et quand je prends d'anciens fichiers 3D, j'ai le même souci de représentation.


Un option oubliée ?

Merci d'avance

Best Answer
photo

Alors ça vient peut-être de votre fichier de configuration. Essayez Options > Configuration par défaut, puis relancez ggb.

Comments (13)

photo
1

Please post your .ggb file

photo
1

Voici.

Et voilà ce que je vois quand je l'ouvre :

/wcH9CiO0Z7g0gAAAABJRU5ErkJgggA=

photo
1

Try making the line thickness bigger for the segments (some of each segment is behind the face so half-solid and half-dashed)

photo
1

Wow... I've never seen this in earlier versions (jump from 382 to 396 and now 399).

Even if i change thickness, result is not really relevant

/w9Z2L3WWkWIwwAAAABJRU5ErkJgggA=

And, as you see, FC segment is dashed, altough in front of me...

Am I the only one that talk about this ? it sounds really annoying to me.

photo
1

Commentaire collé sur l'image.

/x+x8PiZlxipVwAAAABJRU5ErkJgggA=


Grosse différence visible pour le sommet.

photo
1

Comparaison de 4 versions. Il y a quelque chose qui ne va pas...

photo
1

Bonjour,


En effet, les segments à moitié cachés (dans l'épaisseur) apparaissent à moitié en pointillés. Par ailleurs, pour les polygones, on utilise les "couches" (layers) pour éviter le phénomène de "z-fighting" (notamment entre un polygone ABC et le plan xOy lorsque le ABC est sur ce plan). Il est probable que les différences de rendu entre la v5 et la v6 soit le fait du moteur openGL qui est certainement différent dans les deux cas (ça dépend de votre carte graphique).


Pour une solution rapide, je pense que vous pouvez régler votre problème en grande partie en vérifiant que vos objets sont dans la couche 0 (propriétés > avancé). Dans le fichier A0-SolidDot.ggb, le prisme est dans la couche 8; je l'ai replacé ici dans la couche 0, j'espère que ça vous donne un meilleur résultat.


Mathieu

photo
1

Et bien, je n'ai qu'un mot : merci !

Plus qu'une solution rapide, c'est la solution qui me convient.

En revanche, cela soulève une nouvelle inconnue : je m'aperçois que tous les objets que je construis en 3D sont dans le calque 8 par défaut. Dans la doc, je vois que, en théorie, tout se crée dans la couche 0. Et je pense que cela a toujours été le cas dans mes constructions, raison pour laquelle ce comportement est utilisé dans mes anciens matériaux.

Je ne vois pas d'option dans l'onglet de paramétrage par défaut afin de "rétablir" la création dans la couche 0. J'ai désinstallé et réinstallé, mais ils sont toujours créés en couche 8. Comment faut-il procéder ?

photo
1

Parfait !


Pour votre souci de couches pour les nouveaux objets : ggb utilise la plus grande couche déjà utilisée - donc si vous avez un objet en couche 8, tous les nouveaux objets seront créés en couche 8. Est-ce que le souci se produit également en démarrant de rien, après le lancement de ggb ?


Mathieu

photo
1

Oui. Et c'est confirmé quand je trie mes objets par calque dans la fenêtre Algèbre :


/MHOAt7ff5TsEZOA8X4Sq0hUJ1C65CcazjKaRSwsGkUilCJlWuNXu2f8qUjssZGf4PPhjIjRWragVUQS2Yk6rLXUN1OdYLVP8f5MTlC7r6SjEAAAAASUVORK5CYIIA

photo
1

Alors ça vient peut-être de votre fichier de configuration. Essayez Options > Configuration par défaut, puis relancez ggb.

photo
1

Exact !


Etrange que la désinstallation n'ait pas tout réinitialisé (non-suppression des fichiers de configuration ?).

Mais suite à cette manipulation, tout se crée à nouveau dans le calque 0, ce qui résout mon problème d'affichage initial.


Merci beaucoup pour les infos (et avoir pensé à regarder dans les calques, que je n'utilise jamais en 3D [je ne sais d'où vient cette modification]).

photo
1

Super !


Le fichier de configuration est conservé (dans la base de registre si vous êtes sous windows) à la désinstallation.


Bonne continuation,


Mathieu

© 2020 International GeoGebra Institute