Preferences window changing

HenriAugusto shared this problem 7 years ago
Answered

Hi!


I usually do heavy editing of buttons using javascript, and i noticed something that made testing js buttons annoying. I recorded a gif to demonstrate the problem. See it bellow.


Basically when you click a button

1) it is automatically unselected

2) the preferences windows change from Elements properties do View Properties.


I can solve 1 by adding a line on the script ggbApplet.evalCommand("SelectObjects[]"). The biggest problem is 2. Clicking the right properties windows can be tiresome when you're testing a complex js code and need to click the button more than a hundred times.


So i think it would be nice if the properties windows didn't change at all. I know this doesn't affect much users, but maybe it's something not that hard to change.


(I inserted and image in this post, but in case something goes wrong, theres a link to the img on my Dropbox.)


https://dl.dropboxuserconte...


Preferences%20window%20problem


Anyway, thanks a lot for your attention!

Best regards,

Henri.

Comments (2)

photo
1

Is it better if you select the button with a selection rectangle?


BTW you can then use <Space> to run the script, and hold it down for lots of times

photo
1

Thanks for your reply! :)


I can't for some reason select buttons with a selection rectangle. But i don't think that's a problem. The spacebar trick worked on some constructions, but didn't on other. There's a link to a gif below, demonstrating that.


https://dl.dropboxuserconte...


In the second construction, after pressing space bar and executing the button's script, P_2 is selected, wich is, if i recall correctly, the first element i created in the construction. At least the preferences window doesn't change tabs.


This also happens with the other buttons.I tried to solve this by adding on the buttons a command to select themselves. For ex:


On the "AlterarAltura" button the following code:


    ggbApplet.evalCommand("SelectObjects[AlterarAltura]")


but it didn't work. I also tried to add that command to a separate button, but it still didn't. I tried changing the object name parameter to the object caption, but with no sucess.


Here's a gif proving that

https://dl.dropboxuserconte...


I also tried adding " to the parameter


ggbApplet.evalCommand("SelectObjects[\"AlterarAltura\"]")


but with no success.


Now i for a probably more serious thing:

I tried it on a new construction and it did worked. This is bad for:


1) Why it's working only on some constructions?

2) I found a bug when after commenting a line, the 2D view was not being updated correctly. Check the gif:


See the gif below and note how the preferences windows changes again and nothing is selected.


https://dl.dropboxuserconte...

© 2022 International GeoGebra Institute