Polygonzug Problem

Martin Schroedl shared this question 4 months ago
Answered

Ich habe ein Problem mit dem Befehl Polygonzug im der Algebra-Ansicht:


https://www.geogebra.org/cl...


Ich bin folgendermaßen vorgegangen:

Daten in Tabellen-Ansicht eingetragen

Markiert, Rechtsklick, Erzeugen -> Liste von Punkten

Algebra-Ansicht: Polygonzug(l1)


Dabei sollten eigentlich die Punkte "verbunden" werden und eben ein nicht geschlossener Polygonzug entstehen. Ich bekomme aber die merkwürde Ausgabe, die im Link zu sehen ist.


Kann mir hierbei bitte jemand helfen?

Comments (3)

photo
1

n'y a-t'il pas un problème de saisie avec certains points ?


/ARG6sInGAxp0AAAAAElFTkSuQmCC

photo
1

Ah dankeschön! Die Daten wurden aus Excel übernommen und waren dort richtig, daher habe ich diese nicht mehr kontrolliert. Schein ein Problem beim Kopieren der Daten zu geben.

photo
1

Ergänzend zu Noel:

Immer dann, wenn Pfade oder sonstige Obekte irgendwo im Nirwana zu liegen scheinen hilft gelegentlich "rechtsklick in Grafik, alleObjekteAnzeigen/ZoomToFit". Damit wäre Dir rasch aufgefallen, was/wie (in diesem konkreten Fall) falsch ist.

.

Ich empfehle Dir den Befehl Zip() im Manual anzuschauen und ihn wie im Anhang zu verwenden. (siehe auch Listen und Folge)

Damit ergeben sich übersichtlichere, kompaktere Applets. Ausserdem kann damit die Tabelle verändert werden (zB mehr oder weniger Punkte oder neu importieren) ohne dass in der Algebra Ansicht weitere Korrekturen vorgenommen werden müssen.

.

Möglicherweise für Deine Zwecke ebenfalls nützlich ist der Befehl TrendPoly(). Damit kann der Verlauf des Pfades geglättet werden und es wird eine Funktion erstellt, deren Y-Werte man abfragen kann (siehe Anhag).

.

Im Anhang habe ich die von Noel gelb markierten fehlerhaften Werte in der Tabelle korrigiert.

© 2020 International GeoGebra Institute