Multiple Choice in activity not working properly

Marco Rainaldi shared this question 2 months ago
Answered

I created the following activity with some questions in it:

https://www.geogebra.org/m/asbw7qdg

When you get down to the multiple choice questions, they seem to be "scored" incorrectly if "try again" is clicked. I have the correct answers checked on the left when I created the question. However, there is a strange set of check marks and x's that appear if you try and press "try again" is this a bug or am I missing something? I can't seem to find any help in the forum.

Comments (5)

photo
1

It looks they're working properly, but you're expecting to behave them otherwise. In controlling multiple choice questions one can take two possible options: to show all the right answer(s) or to check the options a student has made. I guess you expect the first option, but GeoGebra takes the other one: If you didn't check a right answer, the control will mark the answering as wrong and if you didn't mark a wrong answer the control will mark it as correct. Briefly, every choice of the student is controlled.

chris

photo
1

I see what you're describing, but that seems to only be working properly on the first attempt. After answering correctly the first time in question 2, I changed my answer to sometimes, and I get the following below. I don't think that this should be happening the way you describe how the grading is supposed to work.eea48b68b707307e4685ee867fba7e31

photo
1

it means


negative always <---> error

afirmative sometimes<---> error

negative never <------> rigth

you have three choices yes/no and choice no for never is the only correct

I think is necessary a question with single choice

perhaps you want to do the question like

two points are collinear always/sometimes/never?

type your answer

photo
1

Looks fine to me

photo
1

Why do the green checks and red X's even have to be there? Super confusing

photo
© 2020 International GeoGebra Institute