Mouse wheel only zooms out (will not zoom in)

mcampbel123 shared this question 7 years ago
Answered

I am using GeoGebra 4.0.25.0 (16 March 2012).


When I try to zoom in using the mouse wheel, the graph zooms out.


Either way I scroll, the image zooms out.


My mouse is a Microsoft Wireless Mobile Mouse 4000 in Windows 7 (32 bit).


Thank you for any help on this. I found one article with a dead link that addressed this issue, but the article is useless.

Comments (15)

photo
1

Current version is GeoGebra 4.0.30.0, have you tried the new version? Have you updated your mouse drivers?


Check both of these solution, if the issue persists, upload a ggb file where you are having these problems...


Thanks,


Tony

photo
1

It's a bug with the newer Microsoft (IntelliPoint?) drivers. If you find an older version to download that should fix the problem.

photo
1

It was very easy to update my mouse driver - just click a single button in devmgmt (device manager) in windows 7. Looks like I have the latest.


However with Geogebra, I could not find anything about how to update it!


I searched on this forum, looked in the user guide, etc. I did a search for "update", "update geogebra", etc., and I can't believe it is so difficult to find this out!


Anyways, my question is do I have to uninstall the version I have and reinstall the new version? Or can I just install the new version over the old version. I ask because I have some settings set for Geogebra that I don't want to lose.


Also, I could not find out how to save my Geogebra settings. Is this even possible? I could not find any settings file. My computer recently crashed and I had to go back in and reset all of the settings, which was extremely inconvenient.


Thank you for any help with this.

photo
1

It was very easy to update my mouse driver - just click a single button in devmgmt (device manager) in windows 7. Looks like I have the latest.


You need to downgrade your mouse driver :)


(Your version of GeoGebra is fine)

photo
1

murkle is right, a search on IntelliPoint 8.2 32-bit for Windows 7 details some problems with this wireless mouse, try to get an earlier version of the software.


As to updating GG, click on the GeoGebra logo above and download the latest version there.

photo
1

Does anyone have a specific link as to what the error is?


I couldn't find it.


I suspect the problem is in fact Geogebra, because of the following:


1. The windows mouse works fine in other applications.

2. When I change the settings for the mouse to scroll more quickly,

Geogebra does in fact zoom in. When I set the settings to scroll slowly,

Geogebra will "shimmer", i.e., zoom a little in and a little out, but eventually

only scroll out.


It is NOT a fix to scroll more quickly, since the setting that works for

Geogebra scrolls much to quickly in other applications.


I did read how the microsoft driver sends more frequent, less data, packets

to software for more accurate scrolling. And that some software might only

be able to read the old style of larger packets, less frequently.


But this doesn't seem to be consistent (naively guessing here) with the

symptoms I mentioned above.

photo
1

Does anyone have a specific link as to what the error is?


Sadly, the thread seems to no longer be on the forum, no idea why :(


Google has some of it:

ac1b9e9145f959919e009fa336a03b2e

fd0652c04f7824fa654e9d11ddaf347f

1edb3abeff0e7e3e86991e55239c77f3


BTW it will save you a lot of time if you actually try what has been suggested.

photo
1

Does this help?


http://support.microsoft.co...


Simon

photo
1

ps evidence that it works:

http://www.geogebra.org/for..." rel="nofollow" target="_blank">http://webcache.googleuserc...

photo
1

We've found a bit more from the deleted topic in Google.

After some searching in Microsoft forum I found the solution. It seems a little weird to me, but it works. I changed the type of mouse in IntelliPoint software.

My mouse is Comfort Mouse 4500, I've selected Comfort Optical Mouse 3000 and the problem has gone.

That was not possible in IntelliPoint 8 , so I've installed

photo
1

I had the same problem a year ago, and the solution (published in the accidentally deleted thread mentioned above) is a tricky one... However, it still works for me .. so here is re-post:


--

After some searching in Microsoft forum I found the solution. It seems a little weird to me, but it works. I changed the type of mouse in IntelliPoint software.

My mouse is Comfort Mouse 4500, I've selected Comfort Optical Mouse 3000 and the problem has gone.

That was not possible in IntelliPoint 8 , so I've installed an older version of IntelliPoint software where is the change of mouse type possible (now I have MS IP 7.1 (x64), http://www.oldapps.com/inte...).

--


Hopefully this will be useful for you.


Jirka

photo
1

Well, I uninstalled the 8.0 intellipoint and drivers, rebooted, and installed:


Intellipoint 7.0.258.0 from 5/8/2009.


Same problem.


So this looks like it may be a problem with Geogebra, as I suspected.


Any Microsoft Wireless Mobile Mouse 4000 users out there with the same problem?


Would be interested to see if the problem can be reproduced on a different system to rule out any possible conflicts with the hardware/software I have.


Please post if you have such a problem, since I don't want to start looking for a needle in a haystack.

photo
1

Have you tried changing the mouse type in IntelliPoint?

photo
1

Hello!

I have the exact same problem as you do.


I'm using GeoGebra 4.2.18.0, in Windows 7 Enterprise. The mouse is a Microsoft Wireless Mobile Mouse 4000 and I'm using the standard/stock Windows drivers.


Zooming works fine with the touchpad attached to the laptop, however, when using the Microsoft mouse, it only zooms out, just like it does for you.


I've noticed something interesting; it zooms three "steps" out, then one "step" in.


I hope this can be of any help!

[size=60](And sorry for possible thread necro)[/size]

photo
1

Hello,

I've found a way to solve the issue without actually change driver version:


  • open Microsoft Mouse and Keyboard Center

    select Wheel

    Identify programs that don't scroll correctly

    select Geogebra and all Java elements


12aed0d940e1f0229e36550eb0209dfe

© 2020 International GeoGebra Institute