Maximize screen button not working when embedding with iframe

Eric McKinney shared this question 1 week ago
Answered

Hi there,

First, thank you so much for GeoGebra. This program is incredibly useful.

Second, I am having a hard time getting the maximize button (see attached file for an image) in the bottom right corner of my applet to work. When I upload the applet to GeoGebra.org the maximize button works, but after I embed the iframe

<iframe scrolling="no" title="Binomial Distribution" src="https://www.geogebra.org/ma...; width="1056px" height="561px" style="border:0px;"> </iframe>

into my personal website (https://ericmckinney.net/po...) the button no longer does anything when clicked. My website is being built with the Rblogdown package in R, which uses HUGO a static website generating framework. My hosting service is netlify.com. This may be an issue on my end, but I appreciate the help.

Best regards,

Eric

Best Answer
photo

It's working!

The link that Michael Borcherds provided (https://wiki.geogebra.org/e...) contained the solution. (I thought the link wasn't working at first, but after I reset my browser cookies it loaded.) Thanks, Michael!

The full screen button is a funny feature where you not only have to show it by setting sfsb/true in the Iframe, but you also have to allow it to work by adding the text allowfullscreen to the very end of the Iframe manually.

This is my new working Iframe:

<iframe scrolling="no" title="Binomial Distribution" src="https://www.geogebra.org/material/iframe/id/hytjyavw/width/1056/height/561/border/888888/sfsb/true/smb/false/stb/false/stbh/false/ai/false/asb/false/sri/true/rc/false/ld/false/sdz/false/ctl/false" width="1056px" height="561px" style="border:0px;" allowfullscreen> </iframe>

(The bolded text is added for clarity, and is not meant to be bolded in the actual code. Make sure the allowfullscreen is after the second quotation mark " in style = "border:0px" and before the > symbol.)

You can view the working applet at https://ericmckinney.net/po...

Cheers!

Eric

Comments (12)

photo
1

Make sure you also add allowfullscreen to the iframe tag

How?

Eric wrote (the underline is for avoid editor reduces the link)


<iframe scrolling="no" title="Binomial Distribution" src="https://www.geogebra.org/material/iframe/id/hytjyavw/width/1056/height/561/border/888888/sfsb/true/smb/false/stb/false/stbh/false/ai/false/asb/false/sri/true/rc/false/ld/false/sdz/false/ctl/false"; width="1056px" height="561px" style="border:0px;"> </iframe> 

photo
1

Thank's for your question mathmagic

I have the same problem (sfsb/true is already in the code when we embed it on GeoGebra site)

photo
photo
1

It's working!

The link that Michael Borcherds provided (https://wiki.geogebra.org/e...) contained the solution. (I thought the link wasn't working at first, but after I reset my browser cookies it loaded.) Thanks, Michael!

The full screen button is a funny feature where you not only have to show it by setting sfsb/true in the Iframe, but you also have to allow it to work by adding the text allowfullscreen to the very end of the Iframe manually.

This is my new working Iframe:

<iframe scrolling="no" title="Binomial Distribution" src="https://www.geogebra.org/material/iframe/id/hytjyavw/width/1056/height/561/border/888888/sfsb/true/smb/false/stb/false/stbh/false/ai/false/asb/false/sri/true/rc/false/ld/false/sdz/false/ctl/false" width="1056px" height="561px" style="border:0px;" allowfullscreen> </iframe>

(The bolded text is added for clarity, and is not meant to be bolded in the actual code. Make sure the allowfullscreen is after the second quotation mark " in style = "border:0px" and before the > symbol.)

You can view the working applet at https://ericmckinney.net/po...

Cheers!

Eric

photo
1

Sì, funziona. Perché tuttavia non inserirlo direttamente nel codice che si copia?

Grazie. Un saluto.

photo
1

yep leucotea

why show this button in the code..? if it doesn't work..!

photo
1

Come non funziona? It works!

Prova a cancellare i cookies.

http://splashscuola.altervi...

photo
1

Sorry, not on my site, as Eric

Without allowfullscreen in the iframe code, it doesn't work

With allowfullscreen in the iframe code, it works

cookies or not cookies

photo
1

Infatti avevo richiesto di aggiungere allowfullscreen direttamente al codice, senza doverlo inserire manualmente.

photo
1

Yes, and i agreed with you in my post

I said : "why show this button in the code..? if it doesn't work..!"

photo
1

Scusami, Jumera :). Cattive interpretazioni, il codice per me è questo indicato al link: Show full-screen button. Make sure you also add allowfullscreen to the iframe - tag sfsb /sfsb/true Perciò funzionante. Il problema minimo è quello delll'aggiunta manuale.

Ciao, buon lavoro.

photo
1

Yes... Don't be sorry

I was speaking of the embedded share code

31b7c002ce6f8765ac92178759f8a76f

In the iframe code, it is : sfsb / true > button is shown, but don"t work !

better put in the iframe code : sfsb / true + allowfullscreen... because if we show the button, it is to use it..!

photo
© 2019 International GeoGebra Institute