manual settings histograms in GG6 fail

ccambre shared this problem 3 years ago
In Progress

I tried to make a histogram out of a simple two colum data set. If I chose the one variable analysis -> histogram -> manual settings of borders the screen is totally blank. The statistics interface doesn't work at all.

If I download the file as ggb it's all back to normal, but then I could as well work in gg5.

I uploaded it on https://ggbm.at/snYvjHbu . I just see the two simple colums and no statistic activity.

Added the downloaded ggb5 result.

chris

Comments (5)

photo
1

Hi, try switching to two variable analysis and back to one variable, switching to bar chart and back to histogram.

photo
1

when I click again on the tool the bar chart appears indeed again, and I can change back to a histogram, but every time I check the option to manual settings of the borders, the statistic screen turns blank again and stays blank when I try to select bar chart or boxplot. The only histogram I can show is one with the automatic border settings and surely you often cannot get what you want with the slider. The disappearing is a bug and it needs to be fixed. Nevertheless thanks for trying to find a workaround.

Another thing I just noticed is this: when working with classes, I use a histogram, with seperate data a bar chart, but when classes (or the mids of the classes) are given I' thought I could select the data in two colums and then show the histogram. But then the mids are not interpreted as the mids but as the starting value. So I have to use a bar chart and set the width of the bars so that it looks like a histogram. For a mathematician this is very unlogic and cheeting. In class we emphasis on the difference between the two types of chart, but we have to neglect it all, when using GG.

I'm getting some mails from a teacher I know concerning statistics in GG6, and in this times of examinations she's really desperate how to deal with it.

chris

photo
1

Thanks, we'll check! https://jira.geogebra.org/b...

photo
1

hi

I notice that in 6. 0. 382 manual settings of histogram now already works when selecting a cell range with values, thanks for that.

It doesn't work yet when working with a two colums (with automatic detection of values and frequencies). Hope this will be fixed to.

chris

photo
1

Hi Chris,

just wanted to give an update on this -- we are working on it and hope to fix it next week. By the way for me manual class setting didn't work in case of values + frequencies in GeoGebra 5 either.

Cheers,Zbynek

© 2020 International GeoGebra Institute