Livelli negli strumenti

leucotea shared this question 5 years ago
Answered

Creando un nuovo strumento, i livelli non sono rispettati.

Volevo divertire i miei alunni creando qualcosa di simile a questo.

Nello strumento che si crea i livelli non sono rispettati e alcuni elementi (nel file che allego l'arco- bocca) non risultano visibili. C'è qualche espediente cui si può ricorrere per ovviare la difficoltà?


r.

https://ggbm.at/564127

Comments (13)

photo
1

Ciao Renata,

ho trovato: quando selezioni gli oggetti finali è importante che li selezioni in modo ordinato.

Spero di essermi spiegata altrimenti chiedi.

Sarei contenta di esserti utile, speriamo!!

Alessandra

https://ggbm.at/564131

photo
1

Ciao Renata,

ho trovato: quando selezioni gli oggetti finali è importante che li selezioni in modo ordinato.

Spero di essermi spiegata altrimenti chiedi.

Sarei contenta di esserti utile, speriamo!!

Alessandra


Grazie mille! Proprio così, Alessandra.

Pensa che sciocca, mi era balenata l'idea, solo che mettevo l'oggetto per ultimo pensando che, come nella costruzione con GeoGebra, risultasse primo per livello. Nello strumento avviene appunto l'opposto.

Ciao e grazie ancora.

Renata

photo
1

Ciao Renata,

ho trovato: quando selezioni gli oggetti finali è importante che li selezioni in modo ordinato.

Spero di essermi spiegata altrimenti chiedi.

Sarei contenta di esserti utile, speriamo!!

Alessandra


Hai notato una cosa, Alessandra?

L'arco nel tuo file s'è rovesciato. Insomma lo strumento fa un po' quello che gli pare.

Funziona se non chiudo il file, ma dopo chiuso e riaperto ecco l'esito in GeoGebraTube.

Povero SierGatto.

r.

photo
1

Hai notato una cosa, Alessandra?

L'arco nel tuo file s'è rovesciato. Insomma lo strumento fa un po' quello che gli pare.

r.

Ho forse capito il perché. Un bel... puzzle, se un oggetto dipende da un altro ma il suo livello ha una visualizzazione diversa succede il caos perché l'oggetto deve essere creato per primo per essere visualizzato, ma ciò che lo "sostiene" viene dopo. Chissà se mi sono spiegata.

Resta in ogni modo un mistero del perché inizialmente lo strumento "funzioni".

photo
1

se può esserti utile allego il file dove ho creato lo strumento gnomo.

da quello che ho capito è che tutte le linee devono essere chiuse su una retta

o circonferenza (non deve esserci nessun punto libero).

buonanotte

e.

https://ggbm.at/564155

photo
1

se può esserti utile allego il file dove ho creato lo strumento gnomo.

da quello che ho capito è che tutte le linee devono essere chiuse su una retta

o circonferenza (non deve esserci nessun punto libero).

buonanotte

e.

Nello strumento 'siergatto' non c'erano punto liberi, alfabeta. Lo strumento darebbe quei punti come inizio della costruzione in tal caso.

Buonanotte, grazie comunque.

r.


p. s. - nel tuo strumento poi, alfabeta, gli oggetti non sono opachi e dunque il problema non si presenta, prova a mettere opacità 100.

photo
1

Ciao Renata,

ho trovato: quando selezioni gli oggetti finali

Alessandra


Che sia un bug? Ho inserito un video per mostrare che cosa succede.

Inizialmente lo strumento funziona, e funziona anche riaprendo il file se nel file ci sono oggetti creati con lo strumento.

Se si riapre il file senza che vi siano oggetti creati con lo strumento, questo non funziona più.

Un caro saluto

r.

photo
1

Ciao Renata,

ho passato ieri sera le tue info ai capi, vediamo cosa ci dicono.

Anche sul mancato rispetto dei livelli non sono molto convinta, e a quanto pare anche Miir, però sto parlando "al buio", nel senso che non ho avuto neanche un secondo per aprire e studiare il tuo file.

Quindi per ora aspettiamo.

Ti farò sapere, ciao

Simona

photo
1

Rieccomi Renata,

ciao Simona,

ho visto cosa succede!!!

Ma a me sembra un bug, comunque aspettiamo gli esperti.

Salutoni,

Alessandra

photo
1

se può esserti utile allego il file dove ho creato lo strumento gnomo.

da quello che ho capito è che tutte le linee devono essere chiuse su una retta

o circonferenza (non deve esserci nessun punto libero).

buonanotte

e.

Nello strumento 'siergatto' non c'erano punto liberi, alfabeta. Lo strumento darebbe quei punti come inizio della costruzione in tal caso.

p. s. - nel tuo strumento poi, alfabeta, gli oggetti non sono opachi e dunque il problema non si presenta, prova a mettere opacità 100.


scusami, ero rimasto al file spierpinski-smile, non ho visto il tuo ultimo file.

con l'occasione volevo chiedere se, inserendo il materiale in geogebratube, è possibile lasciare attivo

lo strumento creato in modo da poterlo utilizzare all'interno del file aperto su geogebratube.

un saluto

e.

photo
1

con l'occasione volevo chiedere se, inserendo il materiale in geogebratube, è possibile lasciare attivo

lo strumento creato in modo da poterlo utilizzare all'interno del file aperto su geogebratube.

un saluto

e.

Sì, come hai visto. Nelle opzioni di caricamento si sceglie in Impostazioni avanzate... Mostra la barra degli strumenti.

Ciao

r.

photo
1

Ciao Renata,

Stanno lavorando per te http://jira.geogebra.org/br...

(Commento di uno degli sviluppatori: "poor cat!")

Un pochino di pazienza e vedrai che i tuoi micetti avranno ancora gli occhi al posto giusto!

Ciao,

simona

photo
1

Ciao Renata,

Stanno lavorando per te http://jira.geogebra.org/br...

(Commento di uno degli sviluppatori: "poor cat!")

Un pochino di pazienza e vedrai che i tuoi micetti avranno ancora gli occhi al posto giusto!

Ciao,

simona

Grazie a tutti!

Anche i felini ringraziano ;)

Buon fine settimana.

r.

© 2019 International GeoGebra Institute