Linux repository for GeoGebra 6

ogio71 shared this question 2 years ago
Answered

Hi all,


I'm using Fedora 26 and I installed the repository for GeoGebra pointing to http://www.geogebra.net/lin...


In this repos I can't find GeoGebra 6.

There is a repository for it or I must download the rpm from the download page?


With the repos I can update GeoGebra everytime there is a new version.

Regards

Ambrogio

Comments (23)

photo
1

Ciao,

ti rispondo in Italiano che forse è anche la tua lingua.

Trovi i link per l'installazione qui: https://wiki.geogebra.org/i...

Scorri in basso la pagina fino al paragrafo Altri e seleziona il link che corrisponde alle specifiche del tuo OS.

photo
1

Ciao,


il link riportato porta alla fine allo stesso repository che ho già citato io.

Non è presente la versione 6.

A questo punto la domanda è: Esiste una versione 6, installabile per linux?

Io trovo solo una versione Portable che non è installabile come RPM.


Inoltre penso che la domanda in inglese (ed anche una sua risposta) possa essere molto più utile per chi ha il mio stesso problema e fa una ricerca per vedere se è già presente una risposta.

Grazie per le informazioni già date ed eventualmente per le ulteriori che potrai darmi.

Saluti

Ambrogio

photo
1

Scusa, ma ho appena controllato i link che ti ho dato, sia in Italiano che in Inglese (visto che il wiki lo scrivo io) e puntano a una versione 6, sia a 64 che a 32 bit. Guarda qui il clic sulla 64 bit

77cdea39d22d9827658113608f51d9e1


Io ti ho risposto in Italiano visto che hai postato sul forum italiano :)

photo
1

Buongiorno Simona,

non mi ero accorto (e non mi sembra facile capirlo) di essere nel forum Italiano.


Perdona la franchezza, ma i link che hai riportato tu non sono un repository.

Un repository è un contenitore di pacchetti al quale i tool di gestione del software di Linux si connettono.

In particolare, per Fedora, il repository di Geogebra corretto è http://www.geogebra.net/linux/rpm/ con la sottocategoria che punta a architetture i386 o x86_64.

In questo repository però ci sono solo i pacchetti per l'installazione di GeoGebra 4 e GeoGebra 5.

Non è presente la versione 6.


Inoltre, ulteriore limitazione, il pacchetto in download è una versione .deb (non ben utilizzabile su tutta una serie di versioni Linux che non si appoggiano alla pacchettizzazione debian).

Dato che non esiste solo Debian, e dato che le altre versioni (tra cui Fedora, RedHat, Suse e altri) fanno uso degli rpm, sarebbe buona cosa prevedere una distribuzione di pacchetti anche in formato rpm.


Mi rendo conto che è un ulteriore lavoro in più per gli sviluppatori (non poi tanto ma pur sempre un impegno da mantenere), però non avere la pacchettizzazione rpm è un tornare indietro rispetto alla versione 5.

Al momento non ho bisogno della 6, ma dato che stavo cambiando PC e reinstallando i pacchetti del vecchio mi sono imbattuto in questo argomento.


A mio avviso un prodotto OpenSource molto interessante come GeoGebra non dovrebbe fare scelte del genere e non dovrebbe abbandonare il mondo Linux, tanto più che è sempre più diffuso soprattutto in ambienti universitari.


Apprezzo il vostro lavoro, e spero che questa critica sia costruttiva per voi e non sia vista come la solita lamentela di un utente qualsiasi.


A presto

Ambrogio

photo
2

Zero problemi. Io ho visto "esiste una versione installabile" e sono andata via dritta con i link che ti ho dato.

Adesso sento i Capi e vediamo che mi dicono.

photo
1

Per quanto riguarda la lingua del forum, la vedi in alto.

055ed43f4c32387d7150a4aef83b96f8


Il Forum "assorbe" e utilizza la lingua del browser in uso, quindi se vuoi cambiare la sezione del forum su un"altra lingua basta che la selezioni nel pannello delle Proprietà in alto a destra.


Nessuno sta abbandonando nulla. Michel Iroir ad esempio è un power user, nonchè membro del Team, che utilizza Linux.

photo
photo
1

https://www.geogebra.org/download

down math calculators there is LINUX

photo
1

yes, but no : at home, with linux 64bits the button Linux in the colum for the version 6 is lincked to : http://www.geogebra.net/installers/deb.php?arch=amd64

but I get the : geogebra5_5.0.381.0-556840_amd64.deb version so this button should be in the column : GeoGebra Classic

In the Math Calculators column, we should get what we find with the link at the bottom : "more GeoGebra downloads"; https://wiki.geogebra.org/en/Reference%3AGeoGebra_Installation GeoGebra Math Calculator>Others


  • Linux (deb): 64 bit / 32 bit installers for .deb based systems (Debian, Ubuntu)

(Linux Portable: 64 bit, 32 bit runs from USB memory sticks for example)

photo
1

Hi MiIr, this is what I suggested to the user, but he said it didn't work and pointed to a v.5 instead...

photo
1

Hi all,

this is what I can download when clicking on Linux in the download page:

2512575d1e10516f327cb6422a1c051e


But... the problem is that I don't want to download an installable version, but I'm looking for a repository to be configured on my Fedora Repo (yum or dnf).

If you can"t understand the difference we can continue to link some different pages, but without solving the problem.


Please, have a look at the page http://www.geogebra.net/linux/rpm/ and you will have an idea of what i trying to explain.


Regards

Ambrogio

photo
1

Hi Simona, I confirm for the names, installed, no problem with the 64bits deb version 6 on Ubuntu 16.04.

@ambrogio For the moment, about what I read, we get the install version only for : "installers for .deb based systems (Debian, Ubuntu)" and so, not yet for .rpmlike for the version 5 but it seems that it's coming soon ... smile

You can maybe try something like : http://www.thegeekstuff.com/2010/11/alien-command-examples/

to translate the .deb file from : http://www.geogebra.org/dow... from .deb to .rpm

photo
1

@ambrogio: I'm asking the devs about your request.

Don't know if the happy dev of the week for Linux is in office or on vacation.

So, stay tuned.

photo
1

Well, non problem.

It's not so urgent.

I think that immediatly after the repo will be updated, I can see the change on my Linux system.


Thank you for your time

Ambrogio

photo
photo
1

We will support the .rpm based systems as well for GeoGebra Math Calculators, too. Hopefully we will provide the .rpm packages in a few days. Thank you for your patience until then!

photo
1

Thanks! I am waiting patitently for it too!

photo
photo
1

Hi, Zoltan worked for you, you can now download the GeoGebra Math Calculators (the desktop install last version 6.0.) : https://wiki.geogebra.org/e...

photo
1

Thanks, Michel! In fact the correct links are:


Linux (rpm): 64 bit / 32 bit installers for .rpm based systems (Red Hat, Fedora, openSUSE)

photo
1

Unfortunately, for Fedora 26 these packages require some additional tweaks yet. You need to manually install the packages gmp, mpfr and libXScrnSaver, and then run "rpm --nodeps -i geogebra-math-calculators-6.0.382.0-201708172132.x86_64.rpm" manually. We are working on resolving this problem. (On openSUSE Leap 42.1 the packages should be installed smoothly.)

photo
1

Now the packages should work on both Fedora and openSUSE. I tested the 64 bit versions on Fedora 26 and openSUSE Leap 42.1.

photo
1

Also the 32 bit version works here on Fedora 26 (32 bit).

photo
1

Fedora 27:

Install the repo

sudo dnf install http://www.geogebra.org/dow...
sudo rpm --import https://static.geogebra.org...
Install the package

sudo dnf install geogebra-classic

photo
1

I find problems in working with 3D module: the corresponding window appears but it remains empty

Regards

Mirko

photo
1

Prova a dare un'occhiata alle FAQ qui https://wiki.geogebra.org/i...

photo
© 2020 International GeoGebra Institute