Linux Mint - Geogebra won't run after installing DEB file

Grobe shared this problem 6 years ago

  • Just lost all I Wrote - must write everything over again because
  • This information is shared privately in spoiler and not visible!

Well - I give a short version of the problem.

My OS: Linux Mint 32 bit, Mate desktop.

Reason why downloaded from site rather using Software manager: Only old version of Geogebra is offered.

Install method:

* Downloaded DEB file from Geogebra home site

* Started installation by making Firefox chose to install rather than save deb file locally.

* Installation process: Seems to work well, none visual hint about any errors, no error messages or warnings during install.

Problems after install

There is no entry on "start menu". There is really nothing of Geogebra there.

Serious error messages when attemting to run Geogebra from Terminal. Terminal gives this output:

  1. <username>@<computername> ~ $ geogebra

    GeoGebra 5.0.347.0 24 March 2017 Java 1.7.0_45-32bit

    18:18:08.955 DEBUG: org.geogebra.desktop.i.a.<init>[-1]: isApplet=false runningFromJar=true appletImpl=null

    18:18:08.956 DEBUG: org.geogebra.desktop.i.a.ay[-1]: Setting up logging

    18:18:09.205 DEBUG: org.geogebra.desktop.i.a.ay[-1]: Logging is redirected to /tmp/GeoGebraLog_eytjlswjob.txt


    # A fatal error has been detected by the Java Runtime Environment:


    # SIGILL (0x4) at pc=0x64199f42, pid=10990, tid=1741658944


    # JRE version: Java(TM) SE Runtime Environment (7.0_45-b18) (build 1.7.0_45-b18)

    # Java VM: Java HotSpot(TM) Client VM (24.45-b08 mixed mode linux-x86 )

    # Problematic frame:

    # C 0x64199f42



    Failed to write core dump. Core dumps have been disabled. To enable

    core dumping, try "ulimit -c unlimited" before starting Java again


    # An error report file with more information is saved as:

    # /home/<username>/hs_err_pid10990.log


    # If you would like to submit a bug report, please visit:


    # The crash happened outside the Java Virtual Machine in native code.

    # See problematic frame for where to report the bug.



Log file attached.

Comments (3)


Hi, I'm sorry for you.

I don't know if that will help you :

- of course, you did install the i386 version and not the amd ?

- you don't have any other GeoGebra version installed ?

- did you try the portable version : https://download.geogebra.o...

I have linux mint rosa 32bit and this last version 5.0.347 works fine at home.

Runtime Environment (IcedTea 2.6.8)

Client VM (build 24.121-b00,mixed mode, sharing)


Hi. Thanks for answering.

I'm quite noob when it comes to Linux I must admint, but I answer the best I can:

- Cannot tell what version I installed, it was the one that is linked to at the Geogebra home page. The computer is equipped with an old AMD 2000+ CPU, so wouldn't amd version work too.

- I have no previously version of Geogebra installed.

- I haven't tried the portable version. How do I run these files on Linux Mint?


  1. - I haven't tried the portable version. How do I run these files on Linux Mint?

1. Download the .tar.gz file from


to e.g. ~/Download

2. Extract the .tar.gz file (right click on it then select extract)

3. Go to ~/Download/GeoGebra-Linux-Portable-5-0-348-0 (the repertory extracted)

4. Run the file geogebra-portable (inside the 3.) select run in the terminal.

or, through the terminal (Ctrl+Alt+T), instead of 3. and 4 .

  1. ~/Download/GeoGebra-Linux-Portable-5-0-348-0/geogebra-portable

© 2023 International GeoGebra Institute