Löse findet keine Lösung

mathias.rettich shared this question 3 years ago
Answered

Hallo liebe Formusmitglieder,


Der Befehl Löse({x+y+z=3,x+y-z=1}) liefert mir als Ergebnis eine leere Menge:

e7c5506e984199b1df054870d2382f83

Lasse ich dann die Lösung im 3D-Fenster darstellen findet Geogebra die Lösung:

423e700e7340d7eaf06f1f435cf4bef6

Ach ja, lautet die zweite Gleichung x-y+z=1 so findet Geogebra die Lösung?!?

Mach' ich da was falsch?


Danke schon mal für"s mitdenken.


Gruß,


Mathias

Best Answer
photo

Hallo Mathias!


Der Löse-Befehl im CAS erwartet ja Folgendes: Löse( <Liste von Gleichungen>, <Liste von Variablen> )

https://wiki.geogebra.org/d...


Wenn Du Deine Eingabe um die Liste der Variablen erweiterst, dann sollte es eigentlich funktionieren.

Versuch also mal: Löse({x+y+z=3,x+y-z=1},{x,y,z})


Gruß

mire2

Comments (3)

photo
1

Hallo Mathias!


Der Löse-Befehl im CAS erwartet ja Folgendes: Löse( <Liste von Gleichungen>, <Liste von Variablen> )

https://wiki.geogebra.org/d...


Wenn Du Deine Eingabe um die Liste der Variablen erweiterst, dann sollte es eigentlich funktionieren.

Versuch also mal: Löse({x+y+z=3,x+y-z=1},{x,y,z})


Gruß

mire2

photo
1

Hallo mire2,

das war's tatsächlich. Vielen Dank.

Warum die Lösung angezeigt wird, wenn ich die Gleichung x+y-z=1 durch x-y+z=1 ersetze, ist mir immer noch ein Rätsel.


Gruß,

Mathias

photo
1

Weil Du ein unterbestimmtes LGS hast und


weil Standard-Lösungsalgorithmen so aufgebaut sich, dass sie ohne besonderen Auftrag z als unbestimmte Variable behandeln - was im 2. Fall zum Erfolgt führt aber nicht im 1. Fall...

photo
© 2022 International GeoGebra Institute