Keyboard Disables While Using GeoGebra Web App

harrytomalley shared this problem 5 years ago
In Progress

The Problem:


When using the GeoGebra browser-based app, the keyboard stops working. For example, when I click within an input section within the Algebra view and try to type on the keyboard, nothing happens. This is true even when I pull up the in-house, screen-based, clickable keyboard within GeoGebra. When I click my mouse on a letter or number on the keyboard, nothing happens. Nothing appears in the input section.


I first noticed it while teaching a class last night. My students were using GeoGebra via Safari on iPads and many began complaining about this saying "my keyboard isn't working". It is important to note that I have used GeoGebra in virtually every class for the entire year with these students using these iPads, so it is not the devices. To further back this up, this keyboard issue happened to me directly while using Chrome on a desktop PC today during another one of my classes. It happened to many students in todays class too when they were using Chrome on their Chromebooks to access GeoGebra.


As I stated, I use GeoGebra as the primary tool in my classroom. This has been a completely debilitating experience for me and my students. I plan on using GeoGebra tomorrow. Any chance this can be corrected?


Thanks,


Harry O'Malley

Comments (6)

photo
1

We have noted the same in Sweden, specifically several instances where Chrome was used on Macs. One teacher was (!) planning on having an exam-mode test on Thursday... It is damaging if the students start believing that GG can't be trusted...

photo
1

Thanks for the report! This sounds like a serious issue but unfortunately I wasn't able to reproduce it yet. If you could please give me some more details it would be great: what did you type in algebra view and what was the last action befor it stopped working.


Note that you can still use Menu > View > Input Bar to enter any commands in plain text.

photo
1

I am trying to recreate the keyboard failure now, but can't. However, one other strange issue that often accompanies this keyboard failure is a large white bar that appears at the bottom of the screen pushing the GeoGebra window up. Many of my students also experienced this. I am currently experiencing it right now using Chrome on a PC. I've attached a screenshot. This white bar appears there from the moment I open the web app and select graphing calculator.

photo
photo
1

I've also noticed this problem today. Sometimes, typing stops and you can't enter an input in algebra view - when this happens, clicking on the screen keyboard (e.g. changing to ABC) has no effect. This was in Chrome, clicking on another algebra view item and then trying again usually resolves it. In Edge, at times I found I couldn't open the menus (main hamburger icon).


In all browsers, tools no longer work with algebra view, e.g. I used to be able to choose "turning point" (or "extremum") and choose the curve by clicking it within algebra view - now I must click it in graphics view. Also, right-clicking on an item within algebra view does not bring up a context menu, but seems to act just as a left click.


If a new version of the web app was released recently, might you consider rolling back to the previous one for the time being?


Thanks, Peter

photo
1

The same Swedish user reports that problems persist. The environment is still very buggy in Chrome on Mac, which is the only available option for this partcular class. Typing x^2 does not work so they have to type x*x. Typing in a command immideately gives an error message about undefined variable or wrong number of variables. Also, the tab key does not work to move forward within commands. All combined this is very irritating, especially for students writing tests.


Even though others seem to have problems reproducing this error, it is constantly being reproduced for this particular user and it seems to crop up on some chromebooks and PC's as well.

photo
1

I can also continue to confirm the problems. On top of Chrome on Mac, the same problems occur on safari on an iPad. I also got the problem to happen on a Windows machine using Chrome. It all started when the cursor in the Algebra view turned red. The cursor used to be black. Now it is red. There were no problems in the version where the cursor was black. Ever since the cursor was red, the problems have occurred. That might help identify the update that this began.

© 2022 International GeoGebra Institute