Install Geogebra Classic 6 on OpenSuse Leap 15

Mark shared this problem 9 months ago
New

Hi,

on the download page of Geogebra https://wiki.geogebra.org/e... you can download Geogebra Classic 6 for Linux (in my case OpenSuse Leap 15) as rpm and install it. The parenthesis behind it says that you can install version 6 on openSUSE ≥ 42.1. This would mean that I could install the program on my computer, but I get the message that the package libmpfr4 is missing.6d8b15eb2ad6a47551468bbe58c78b2cBut this isn"t available for this OpenSuse version.


Does Geogebra Classic 6 need an update, so it can be installed on newer systems? Now i'm using Geogebra Classic 5 and I would like to upgrade to 6. So if someone can tell me a solution for this problem, thanks.

Comments (2)

photo
1

The .rpm package is indeed broken. However, you can still install it by forcing every step, at least I could do that with 6.0.546.0 on a fresh Leap 15.1 install. A missing dependency was gconf2 that could be installed with sudo yast -i gconf2.

photo
1

The .rpm package is indeed broken. However, you can still install it by forcing every step, at least I could do that with 6.0.546.0 on a fresh Leap 15.1 install. A missing dependency was gconf2 that could be installed with sudo yast -i gconf2.

© 2020 International GeoGebra Institute