I have changed the colors of the axes to black.

AlphonsoLo shared this question 3 years ago
Answered

I have changed the colors of the axes to black using SetColor(xAxis,Black), SetColor(yAxis,Black), and SetColor(zAxis,Black).


However, when someone opens up my shared link (https://www.geogebra.org/3d...), they see the axes in their default colors of Red, Green, and Blue.


What's going on and how do I make sure that anyone who opens up my link see that the axes are black?

Comments (9)

photo
1

https://help.geogebra.org/topic/changing-color-of-the-plane

Juan Carlos Ponce Campuzano:

  1. function ggbOnInit() {
  2. ggbApplet.evalCommand("SetColor[xAxis,0,0,0]");
  3. ggbApplet.evalCommand("SetColor[yAxis,0,0,0]");
  4. ggbApplet.evalCommand("SetColor[zAxis,0,0,0]");
  5. ggbApplet.evalCommand("SetColor[xOyPlane,0.8,0,0]");
  6. }

photo
1

Hy,

I have a problem with coloring axes. I can change the color in black, however, when I want to export or save the image, colors automatically became the default and I can not save the image with new colors. Can you help me?

photo
1

I'm sorry but cannot replicate your issue, in both the latest versions of GeoGebra Classic v.5 and v.6.

I've changed the axes colors by deselecting the Coloured axes option in 3D Graphics properties panel, then exported as image. No need to add scripting for this, now.


Please check if your GeoGebra app is updated and try again. If the issue is still there, please tell us which is the GeoGebra app you are using, its version and your OS.

photo
1

Can you tell me all the steps which I need to use if I want to export an image?

photo
1

Sorry, now I updated my version and the issue is still there. Geogebra classic 6, version 6.0.560.0 and I use ubuntu.

photo
1

I use Windows, but the steps are the same.


Click on 3D View to activate it.

Select the menu icon on top right (three stacked lines), then select Export Image in the appearing menu.

A preview of 3D view appears, with two buttons: one is to copy the image to the Clipboard of your system, so it can be pasted into another app (e.g. Word processing), the other one is Download.

Click the Download button to save a copy of the image locally.

The File Explorer opens. Select a folder, then accept or change the default name of the file (it is usually geogebra-export.png). If you change the name of the saved file, don't delete the extension .png).

Press Save to confirm.

photo
1

Yes, I know it and I work like you.

Firstly, in input bar I write: setcolor(xAxis,0,0,0), setcolor(yAxis,0,0,0) and setcolor(zAxis,0,0,0). After that, I draw two planes and their intersect. On the end, I want to export the image, but when I select the menu icon on the top right, the colors of the axis become the default. And I don't know where is a problem?

photo
1

Don't do that. SetColor command doesn't work for this.

Use the 3D Graphics settings instead. (This thread is rather old, so some advices in the first comments are now outdated)


Right click in an empty area of 3D Graphics View, then scroll down the context menu and select 3D Graphics...

In the Axes tab of the appearing Properties panel, deselect the Colored axes option.

Close the Properties panel, and export

photo
1

Ahaa, now is OK. Thank you so much.

photo
© 2021 International GeoGebra Institute