How to create a tool in Geogebra Classic 6

ET66044 shared this question 1 month ago
Answered

Comments (10)

photo
1

See the tutorial for GG Classic in the chapter Advanced: create a custom tool

https://www.geogebra.org/m/XUv5mXTm

photo
1

After having created a costumized tool, I can not open it in another sheet to use again with Geogebra6 as I was used to do with Geogebra5... Is there any difference that I show know?

photo
1

I just read it and it says what I was used to do with Geogebra5 but in Geogebra6 I have problems saving the tool on the "managing option"... It saves it incorrectly and then I can not open it in another file...

photo
2

I suppose one way to get around the problem in geogebra 6 is to "clean" the file (deleting all objects) and saving it and using it as a template.

But I have saved custom tools to my files as a ggt-file, then opening a new file, press open/file and clicked the ggt-file but geogebra just responds with "loading,,," forever.

It would be great to hear how this can be solved.

Best regards

Ketil Bergesen

photo
1

Exactly, it happens the same with me, it keeps "loading,,," forever and never loads nothing.

It is a good idea to delete everything and use it as a template but, as you say, it would be great to hear how this can be solved.

Thank you for your ideia.

photo
3

I found a better way, that works for both 5 and 6:

- Open the file with some custom tool in 5.

- Go to manage tools and choose save as filename.ggt locally on your computer.

-Then open the file in 6 and drag the ggt file(s) into the the graphics view.

-The tool then appears in your toolbar.

-NB! Does not work from the online site (but that youalready know :)

Best regards

Ketil Bergesen

photo
1

Thank you so much, Ketil! The other one worked but only for tools created in the same ggfile. With this new option you discovered, I can import tools created in different files ;) thank you so much.

Another thing that I notice is that the boolean geogebra boxes are not working in GGB6, can you tell me if it is the same for you too?

Thanks again,

Sofia

photo
1

A pleasure! I have struggled so much with tools myself :)

Yes, I have had also the problem that they are irresponsive (frozen), but saving, closing and opening the file again have made them work again - not always though, it must be a bug.

By the way, I forgot to mention in the last post, I also saved settings in goegebra 5, so each time I open a file there my tools appear in the toolbar without importing them.

Best regards!

Ketil

photo
1

In fact, after saving and opening it worked 👍

It makes sense what you added now!

Great ideas and experience you have!

Thank you 😊

photo
1

De nada!

photo
© 2021 International GeoGebra Institute