Graphical bug in Geogebra

Tommy Pham shared this problem 6 years ago
Not a Problem

Geogebra has a graphical bug when i use it on my PC

http://prntscr.com/cbrjuy

http://prntscr.com/cbrk12

it's almost like it's lagging as in the old windows XP

I've tried reinstalling Java, deleting temp files from java.

Reinstalling Geogebra, downloaded the portable version of Geogebra but all the bugs still remain.

This makes the program virtually impossible to work in.

I am using Geogebra 5.0.270.0-3D (Java 1.7.0_40-32bit, 247 MB, CAS initializing)

26 august 2016

I use an Nvidia 780 and windows 10

Comments (10)

photo
2

Sorry, that's a bug in the Graphics Drivers so you can try upgrading (or downgrading them) - maybe look for a beta version.


If that doesn't help, the "App and Exam" version will hopefully be OK:


https://www.geogebra.org/ma...

photo
1

Doesn't it seem a bit funny to you that so many different people all of whom have different graphics cards with different drivers all have the same bug seemingly only with geogebra? this has nothing to do with our graphics drivers. this is a problem with geogebra

photo
1

No (actually it affects eg Minecraft too)


https://wiki.geogebra.org/e...

photo
photo
3

Hello there dear user of GeoGebra!

This is a very short guide for how to fix the annoying graphical bug that has been occuring for many users over the last year or so. I've had this problem myself, and since seemingly noone has been able to solve it I decided to do it myself. Here is how:

1. Find where your "GeoGebra.exe" file is located.

2. Right click "GeoGebra.exe" and press "properties".

3. Left click on "compatibility".

4. Tick "compatibility mode" and set to Windows 95. This is VERY important as the other options wil not solve the problem.

5. Tick "run this program as administrator" to make sure the program is running correct.

Enjoy your now fully-functioning GeoGebra!

(Sorry if some words are incorrect, my native language is not English)

photo
3

Hi,


Compatibility mode set to Windows 95 makes Geogebra crash for me (with Win 10)

So I set it to Windows XP (service pack 3) and it works fine. No more crash, no more graphical bug.


Hope it can help you.

photo
2

I had the same problem with win 10 and Radeon graphic chipset. According to your suggest I set Compatibily mode Windows 98. Screen doesn' dance no more. Thank you very much!

photo
2

I am also experiencing this bug on a Windows 10 PC with a I5 6600K and a GTX 1060 Nvidia drivers version 375.70. This bug should be fixed for newer os and newer graphics drivers.

photo
2

I think I did what Hundblukat suggested, at least in part. found the compatibility already set to windows xP Sp3 so I just set it to run in administrator and problem went away. Very strange. I also lit a candle, jiggled the keys and recite my secret chant from when I was a tech 30 years ok (worked on Dec 8E.s).

photo
1

See here for a couple of other solutions:


https://wiki.geogebra.org/e...

photo
1

after so many hours of googling, i found this page. and thanks u good peoples.

my black screen problem for geogebra with obs is solved. it worked for me with compatibility win 7 mode.

© 2022 International GeoGebra Institute