GeoGebra startet in Zeitlupe

andschuster shared this question 13 years ago
Answered

Hallo,


ich habe mir gerade die neueste Version von GeoGebra auf meinem Laptop (Pentium M, 512 MB) unter Windows XP installiert. Der Start dauert geschlagene 105 Sekunden. OpenOffice hingegen, das ja auch nicht gerade durch schnellen Start "glaenzt", benoetigt gerade einmal 15 Sekunden. Diese Startzeit von GeoGebra erscheint mir (beim Einsatz vor der Klasse) inakzeptabel. Laesst sich das irgendwie beschleunigen?


Gruesse


Andreas


PS: Wann erscheint eigentlich nun die Linux-Variante der neuesten Version? Sie ist ja schon seit langer Zeit als "demnaechst" angekuendigt.

Comments (8)

photo
1

Die Linux-Variante existiert als Webstart seit Ewigkeiten und der Beta-Test der Installers sollte Ende August starten. Wegen des Erscheinens von InstallAnywhere 8 wurde er auf nächste Woche verschoben (es bringt nichts etwas zu testen was anschliessend direkt wieder geändert wird)...


Soll ich Dich auf die Liste der Beta-Tester für Linux setzen?


lg,

Yves

photo
1

Wegen der Startup-Zeit: 105 Sekunden sind in der Tat sehr viel, aber auch nicht normal fuer GeoGebra. Der Grund fuer die laengere Startzeit von GeoGebra oder Open Office ist Java: Es muss zuerst die Java Virtual Machine gestartet werden, in der dann Java Programm wie GeoGebra oder Open Office laufen.

GeoGebra braucht bei mir und WinXP ca. 5 bis 10 Sekunden, um zu starten. Wenn es sehr viel laenger dauert, duerfte mit der Java Installation irgendwas nicht passen - natuerlich haengt es auch mit deiner Prozessor-Power zusammen. Sun bemueht sich natuerlich, die Startzeiten bei neuen Java Versionen zu verringern. Ich hab grad mal die Java 6 Beta Version ausprobiert und hatte das Gefuehl, dass da GeoGebra recht flott startet (ca. 4 Sekunden, bis man arbeiten kann).


Da faellt mir ein: hast du GeoGebra durch Doppelklick auf eine Datei geoeffnet? Falls ja, vielleicht liegt ja dort ein Problem bei der Vearbeitung der Datei - das waer dann GeoGebra-seitig und ich koennte was tun.


Schoene Gruesze,

Markus

photo
1

Hallo,


ich habe GeoGebra heruntergeladen und auch die auf der Downloadseite verlinkte Java-Version. Nach der Installation von Java habe ich dann GeoGebra installiert. Nach dem Abschluss befanden sich auf meinem Desktop zwei GeoGebra-Symbole, ueber die ich das Programm starte. Laesst sich hier etwas machen? Ich glaube nicht, dass es etwas mit meiner Hardware zu tun hat. Das Notebook hat einen Pentium M mit 512MB Hauptspeicher. Alle anderen Programme, die ich bisher verwendet habe, starten sehr schnell. Auch OpenOffice startet, wie weiter oben schon erwaehnt, sehr flott (ca. 10s).


Viele Gruesse


Andreas


EDIT: Ich habe Geogebra jetzt per "java -jar geogebra" direkt aus der Konsole gestartet. Das geht blitzschnell. Es scheint also doch an deinen EXE-Dateien zu liegen.

photo
1

Hast du GeoGebra Webstart UND die Download-Version installiert (welche Version)?


Bei WebStart wird bei jedem Doppelklick nach einer neueren Version am Server gesucht. Vielleicht ist das der Grund...

Die .exe Dateien sind eigentlich nur Wrapper fuer den Kommandozeilenaufruf, da sollte nicht viel passieren.


Hast du mehrere Java Versionen installiert? Vielleicht kommt sich da ja was in die Quere.


Gruesze,

Markus

photo
1

Hallo,


ich habe nur die Downloadversion installiert (nicht GeoGebra WebStart!), und zwar die neueste Windows-Version (2.7.1.0), die auf deiner Webseite zur Verfuegung steht. Das Java habe ich von "http://www.java.com"; (wie auf der Downloadseite angegeben) heruntergeladen und installiert.


Viele Gruesse


Andreas

photo
1

nochmal: hast du mehrere Java Versionen installiert? Falls ja, aktiviere in der Systemsteuerung verschiedene Java Versionen, checke mittels "java -version" in der Kommandozeile, dass das auch funktioniert hat, und starte dann GeoGebra mittels Icon-Doppelklick jeweils mit verschiedenen Java Versionen.

Gibt's da Unterschiede?


Im Zweifellsfall: GeoGebra runter, alle Java Versionen runter. Rechner neu starten. Java 1.5 rauf, GeoGebra rauf. Es lebe Windows ;-)


lg, Markus

photo
1

Hallo,


nein, auf meinem Rechner befindet sich nur die eine Java-Version, die auf der Downloadseite von GeoGebra verlinkt ist.


"By the way": Ich lese gerade eine Arbeit, die sehr stark auf GeoGebra fusst. Dort wird fuer die Ableitung nicht der Befehl "Ableitung[]" angegeben, sondern "Ableitungsfunktion[]". War das frueher so in GeoGebra?


Viele Gruesse


Andreas

photo
1

bezueglich des langsamen Startes auf deiner Maschine bin ich ehrlich gesagt ratlos. Es duerfte aber irgendwie mit deiner speziellen Konfiguration zusammenhaengen...


Ad Arbeit: welche Arbeit ist das? Bitte Link bzw. genauere Infos dazu angeben. Den Befehl "Ableitungsfunktion[]" hat es nie gegeben, er hiesz und heiszt "Ableitung[]".


Gruesze,

Markus

© 2020 International GeoGebra Institute