Geogebra crashes in 3D mode

mail_lfrancois shared this problem 2 months ago
Not a Problem

Hi,


If I try to open a .ggb file containing 3D object, the file won't open. I just see the Geogebra logo appear and then its gone and nothing happens.


I can open Geogebra in 2D mode (and use it normally), but as soon as I try to go in 3D mode, it crashes.


I'm using Geogebra classic 5.0.560.0 on windows 10 home, 64-bit, with a Geforce GTX 950. I have tried using the mobile and the installed version. I also installed the latest graphic card drivers.

Comments (6)

photo
2

I won't deny that GG crashes on your computer, but If 3D crashes it has to be a hardware question. GG5.0.560 in win10 is working fine as it was in previous versions. You can try the webversion, which should work

chris

photo
1

Yeah the web version works fine, but what do you think I can try doing to pinpoint the issue? Some setting in the NVIDIA pannel maybe?

photo
1

I'm sorry but I'm not an expert in drivers. If you ve'got a good computer dealer you can ask about the features of your computer and the available drivers

photo
1

By the way, did you try GeoGebra Classic 6? THis too can make the difference.

photo
2

I see two different drives for your graphics card in the official page


you can try another drive or uninstall and reinstall

you can ask at official service also

photo
2

If you are using a laptop, you usually have an inbuilt GPU on the motherboard (usually an Intel one) and another one (that might be the NVIDIA). Laptop use the inbuilt Intel one by default, unless you specify to use the NVIDIA one for some/all your installed apps.

If this is your case, please check the Intel drivers. If you successfully updated to the latest 1903 windows update, they should be ok, and compliant with 3D in GeoGebra. If you haven't, you might have older drivers. Some old Intel drivers had a bug that prevented some 3D apps to work properly.

© 2019 International GeoGebra Institute