Geogebra Classic 6 will not open/start

fridabarland shared this problem 1 year ago
Solved

I have Geogebra Classic 6 version 6.0.496 on my Mac OS High Sierra version 10.13.6. When I open the app (that i downloaded from App Store), the app name shows up in the left corner of the screen (which it usually does when all apps or browsers are open), but no window.

The name in the left corner of the screen indicates that Geogebra has been opened, but there is no window.

I have tried restarting my mac, deleting and reinstalling the app from App Store, and I also tried downloading the portable version, but none of them will open.

Comments (6)

photo
1

Hi, got the same problem. Suddenly from one moment to another the program stopped working: the same than fridabarland stated above, the bar will show the program as opened but no window at all will be shown.

I tried deleting the app and reinstalling, cleaning files, reinstalling java, nothing will work except older versions. GeoGebra Geometry and Graphing Calculator work perfectly, the problem is just with GeoGebra Classic Geogebra is 6.0.496. My Mac OS is Mojave 10.14.5.

Any suggestions how to solve? Thanks !

photo
1

Thank you for the report.

I can't check because I'm not using a Mac, but I'm looping your report to the Support Team.

In the meanwhile, you can:

- check for the latest version available in the Apple Store

- use the online version: https://www.geogebra.org/classic

- or try the Portable version (please note that this is a standalone version, doesn't modify your system, you can run it also e.g. from USB memory stick, and does NOT update automatically)

photo
1

Thanks Simona for reply.

I tried both the last version and from the Apple Store and the portable one but they don't work neither.

Looking forward for a solution (using the online version in the meantime).

photo
2

Databases, settings and caches are distributed troughout the system, and are often not taken into account during uninstallation. So please uninstall GeoGebra and also try to delete the following folders.


  1. Open Finder
  2. Hold down Alt (Option) and choose Go from the dropdown menu bar at the top of the screen
  3. You will see the ~/Library folder

Go to the following folders and search for subfolders which are connected to GeoGebra 6. Delete these GeoGebra folders and install GeoGebra Classic 6 again.

Search for GeoGebra folders in Application Support, Saved Application State, Preferences and Chaches.

photo
1

Worked perfectly! Danke Julia! I thought would be enough using a program to clean the files (such as ccleaner) but no, it was necessary to clean the computer manually as you pointed.

Thanks again, have a wonderful day.

photo
1

just new joined this forum , hope can help you next time.

i am a full time teacher , as a tutor, and hope can help more students

photo
© 2020 International GeoGebra Institute