Geogebra 3d missing

Bjørn-Tore Lund shared this question 3 years ago
Answered

Greetings.

When you open Geogebra the 3D calculator is showing, but after loading the graphics, it vanishes. I checked the settings and can't see a way to fix this?

I work in the it department at a high school, and one of our teachers reported this issue.

Comments (18)

photo
1

I can see it both on v.6 installed and the online version of Classic v.6

Which version of GeoGebra Classic are you using, and which is your OS?

photo
1

V6 installed on both my computer and the teachers. We're both using W10.


I tried to switch language settings to English, thinking it might be that since it shows in English before loading the graphics, but it didn't help.

photo
1

I also attempted to delete the %appdata% folder, but that didn't help either.

photo
1

I don't think that the problem is related to the GUI language, and if you're Swedish, your language has full support in ggb.

Can you use it online, here? It might be a workaround, for the time being. https://www.geogebra.org/classic

Are you using the latest version of ggb, that is v. 6.0.426 ?

photo
1

Can you please remove this topic as "answered"?

Not sure why it's tagged as answered, but we still have the same problem, and if editing a line in JS is the solution as suggested below, that's not something we can be expected to do manually to all the students, you will have to update the software.

photo
photo
1

Hi. The teacher was aware of the online version and is currently using it as a workaround. Thank you for the advice however.

I am using 6.0.426, yes. I downloaded the new Geogebra 6 today on my computer to look into the issue. The teacher has Geogebra 6, but I'm not sure what version.

Seems odd that I would get the exact same issue when downloading a fresh install today, and nobody else struggling with this?

Norwegian by the way, not Swedish.

photo
1

Norwegian is fully supported, too. I've checked right now.

Anyway, I've told the Devs if they have any idea about why is this happening, since we hadn't other people with the same issue, and you said that you deleted the C:\Users\<username>\AppData\Roaming\GeoGebra folder

photo
1

Any news from the devs?

photo
1

Are you still having issues with opening the 3d view?

Can you see it listed in the Oppsett menu?

Are you able to select it?

bad6815e14159b202a28b55760460dab

photo
1

Hi,

same problem with german language setting ;-) Greetings to Norway. We will visit it again (and again, and again..) at spring and summer :-)

online is working without problem.

Version 6.0.356.0-offline, Windows 10

Strange: Some notebooks at our school work with 3D, the most of them don't.

'3D' disappears a few seconds after geogebra starts.

Thanks for Your help,

Axel

photo
1

Running the portable version classic 6 produces the same error.

The portable version 5 shows the message 'Can't find the name of Intel ICD OpenGL driver' if i open 3d.

OpenGL works in Chrome and Firefox.

Intel HD Graphics 520, driver 21.20.26.4627

AMD Radeon R5 M330, driver 16.300.2101.0

photo
1

Greetings to Germany ;)

As you can see, Simona, 3d isn't showing.

photo
2

Found a solution in : https://wiki.geogebra.org/e... ************************************ Try adding the line app.commandLine.appendSwitch('ignore-gpu-blacklist', 'true'); after the line const {app, BrowserWindow, Menu} = require('electron'); which is around line 24 in resources/app/main.js ********************************************************** On the Windows notebook You find it in c:\Programme(x86)\GeoGebra Math Apps\resources\app\main.js I found the line as the first in the file. So I added into the second line. We will try, if it works on all of our foolish notebooks at school. Ha de bra, Axel

photo
1

Geogebra 6 doesn't install itself in the normal programfiles(x86), it can only be located in %appdata%, and it doesn't have the sub-catagories you speak of.

No idea why this is registered as answered :s

photo
1

I have a similar problem but in completely different circumstances. I run Chrome OS on a Chromebox, not a Chromebook. It has worked smoothly with Geogebra for several years. All of my software comes from here: https://chrome.google.com/w... . A couple of weeks ago Geogebra 3D disappeared. I updated my OS, went to the Webstore and downloaded GeoGebra Classic

offered by https://www.geogebra.org

(2056)Academic Resources1,630,918 users

I also downloaded GeoGebraoffered by yucheng1884

(0)Accessibility21 users

Neither of the downloads will open Geogebra 3D. I went to Google Play: https://play.google.com/store?hl=en I began to read this: GeoGebra 3D Graphing Calculator


International GeoGebra InstituteEducation


/fDrMd6BZDQGe1-ND2uyWviZx2O_Tqssk8pvmVEvXdJRvYtMz4c-LFPfB6C5qdAC-mCqFN4Iptr_Fv54e=s14-rwEveryone


2,653

You don't have any devices. My Chromebox is not compatible with Android software. My Chromebox has become obsolete. I can still run Geogebra except for 3D. I tried to open https://www.geogebra.org/3d The icon spins, but the page does not open. I opened https://www.geogebra.org/classic . It opens 2D; however, 3D is blank. I can open and use https://www.geogebra.org/graphing .

photo
1

Sorry, if you can't update ChromeOS then we can't help

photo
photo
1

Please try the latest version (v485+)

photo
2

Ok, das passt ja.

Bei mir funktioniert seit einiger Zeit die 3d-Darstellung unter GeoGebra5 nicht richtig. (auch in der portablen Version taucht das Problem auf)

Nicht richtig funktionieren heißt hier - der Laptop wird extrem langsam und auf einem externen Monitor wird gar keine 3d-Graphik angezeigt

Unter GeoGebra6 funktioniert sie aber problemlos, weshalb es wohl nicht an der Graphikkarte liegt, sondern eher an der Java-Einstellung.

Ich meine mich zu erinnern, dass es hier im Forum mal mögliche Lösungsansätze gab, kann die aber leider nicht finden.


I have problems with the 3d-view under GeoGebra5, even the portable version.

Under GeoGebra6 everything works fine, so I presume, that Java is responsible for it.

I remember, that Simona or/and other (?) gave some hints (deleting a folder or something else...) to fix this but I can't find.

My system:


Windows 10 Pro

Intel HD Graphics 520, driver 22.20.16.4811

Intel Core i5-6300


Thanks for help and a nice sunny sunday

mire2

© 2021 International GeoGebra Institute