Error with 3D view on Windows 10 machines with Intel grafics

Werner_R shared this question 3 years ago
Answered

On many, relatively new computers (mostly laptops, some Desktops) I have seen this error.

GeoGebra is running fine, but when starting 3D view, I get this error:

"Can’t find the name of Intel ICD OpenGL driver"

an then GeoGebra hangs.


This is a problem with GeoGebra only, not with other grafics software on the same computers.


Comments (6)

photo
1

It's not a problem with just GeoGebra, but it happens also with other software and platforms (e.g. Steam) and it's related to a bug in the generic Intel drivers provided by Microsoft with Win 10, mainly on machines using dual GPU, an onboard one+ a dedicated one.

Intel has released new drivers that solve the issue. Please check the Intel site to find the drivers for your computer configuration.

Version 6 of GeoGebra is immune from this issue.

If you want to read all the story about this fix by intel, see e.g. https://help.geogebra.org/t... or use the Search bar here in the Forum with the key opengl


If you want a quick reference that is ok not only for Surface, but also for other Windows based computers, see https://help.geogebra.org/t...

photo
1

Anyway, GeoGebra doesn't hang. Just Press OK in the warning window that shows the error message, and keep pressing it until the warning disappears and GeoGebra works (you will need about 5 or 6 clicks)

photo
1

Many thanks for your quick responses!

Obviously the behavior of the error depends on the hardware. It`s not the same on all machines.

A friend has an ASUS Laptop. On this machine GeoGebra Version 6 works, Version 5 creates the error. His sister has a Lenovo Laptop. On this machine both versions are creating the error.

My own Laptop is an ACER with Intel HD Graphics 520 (additionally Nvidia Geforce 940MX). On this machine GeoGebra 3D view works fine with a very old Intel HD Graphics Driver 4494 (from 25.07.2016). With newer Intel Drivers the reported error occures and I can click <OK> as much as I like, it hangs.

So I had the idea, to install the Intel 4494 Driver (working fine on my ACER) on the Laptops of my friends, but it is not compatible with their Hardware, so we have no solution yet.


photo
1

Same problem here. But, I change the graphic card for the GeoGebra (chose the 940mx) instead the onboard (intel hd 620).

Then, the GeoGebra doesn't close when I open 3D window. But, it's still there's a black screen and some shadows.

I tried new drivers for both graphic cards, but the issue remains. Now, I'll try to get familiar with GeoGebra 6, wich worked fine here (sorry for the bad english. I've failed all my english teachers and I live in shame for that kkk)

photo
1

I find a way that solve the problem.

Uninstall the geogebra.

Right click in "my computer"-> "device manager". And, then, disable and remove the intel graphics. (choose the option: remove the driver from computer)

Reboot the notebook. Try to install the driver direct from the "Intel" site. Reboot the notebook again and install Geogebra 5.

It works for me.

The issue was the Lenovo Vantage, that try to manage the drivers and don't let upgrade the drivers. So, when remove the drivers, become possible to install them from Intel site.

© 2021 International GeoGebra Institute