Einstellung Punktbezeichnung ändern?

Petrus3743 shared this question 2 years ago
Needs Answer

Comments (22)

photo
1

Wie kann ich, die für mich nicht relevante Punktebezeichnungen, durch einen Änderung der Einstellung ohne Anzeige erreichen? siehe Dateieanlage

photo
1

Nachtrag:


Das Ziel sollte generell für sämtl. Bezeichnungen sein: Anzeige der Algebrabezeichnung für Wert (z. B. ) c_1: ohne <sub><front size="-1>1</front></sub>:


Die im Beispiel fett geschriebenen Angaben helfen mir nicht.


Für die Bemühungen ein Dankeschön im Voraus!

Gruß Petrus3743

photo
1

Deinen Nachtrag habe ich erst gelesen, nachdem ich geantwortet habe.

Ich bin mir nicht sicher ob ich Deine Frage richtig verstanden habe. Falls ja:


  • Rechtsklick auf den Punkt oder dessen Bezeichnung oder auf das Objekt in der Algebra-Ansicht.
  • Es erscheint ein Kontext-Menu für diesen Punkt
  • Dort "Beschriftung anzeigen" anklicken (das ist eine flip-flop Schaltfläche zum ein- und aus-schalten der Beschriftung)

-----------------------------------------------

Frage meinerseits:

wo wurde <sub><front size="-1>1</front></sub> definiert und was bewirkt es?

photo
1

Servus rami,

bei mir erscheint diese eigenartige Punktebezeichnung nicht bei einem Punkt c oder C, sondern bei einem Punkt mit Indexnummerierung (tiefgestellte Zahl) z. B.: c_1 oder C_1. Der wird entweder autom. vergeben oder ich ändere z. B. die Punktebezeichnung A in z. B. A_1. Es stört den Überblick.

photo
photo
1

Nachtrag (geupdatet):

<sub><front size="-1>1</front></sub> scheint irgend etwas mit den Standardeinstellungen zu tun haben. Die normalen Bezeichnungnen in der Algebra-Ansicht erscheinen bei mir wieder, nachdem ich

Menu / Optionen / Standardeinstellungen wiederherstellen gewählt habe (siehe Anhang)

.

Möglicherweise musst Du vorab diese Aktion ausführen


  • Delete this folder: C:\Users\<username>\AppData\Roaming\GeoGebra 5.0
  • This is a hidden folder, so can be hard to find. One way is to press <Windows>R and then copy and paste this (changing <username> to your Windows username)
  • explorer /n, /e, /select, C:\Users\<username>\AppData\Roaming\GeoGebra 5.0
  • then right-click -> Delete

photo
1

Die von dir angehängte Datei hat die Algebra-Einstellung

  • Algebrabezeichnungen: Definition -> Anzeige i.O.

Nach dem Einstellung der Algebrabezeichnungen: Wert -> Anzeige mit dem oben beschriebenen Problem <sub><front size="-1>1</front></sub>

Vielleicht kannts du mir die gleiche Datei nochmals senden nachdem du die "Algebrabezeichnungen: Wert" eingestellt hast?

Die Wiederherstellung der Standardeinstellungen mit anschließendem "Einstellungen speichern" führt nicht zu einer Verbesserung.

Nun versuche ich nach deiner LIste vorzugehen...

photo
photo
1

Das Vorgehen nach der Liste sowie die Deinstallation und erneute Installation von GeoGebra Classic 5.0.488.0-d brachte keine Verbesserung...

photo
1

Ich habe die Vermutung, dass eine verseuchte GGB-Datei in der Lage ist Roaming/Geogebra 5.0 zu verseuchen und umgekehrt. Der Fehler entsteht ebenfalls, wenn man Menu/Datei/SpeichernUnter verwendet (möglicherweise nur bei dieser Datei)

Folgendes Verfahren führt bei mir zum Erfolg. Sobald aber wieder eine verseuchte GGB-Datei geoeffnet wird oder Menue/Datei/SpeichernUnter verwendet wird, ist der Fehler wieder vorhanden, und Roaming/Geogebra 5.0 ist wieder verseucht.

Die Folgende Anweisung ganz genau so und ohne die Reihenfolge zu ändern, ausführen

.

.


1. Erstellen einer unverseuchten Version

1.1. 01-21 Oeffnen und als 01-22 abspeichern

1.2 01-22 mit ZIP oeffen (allenfalls die Dateiendung vorab auf .zip umbenennen)

1.3 in der Zip-Dateiliste geogebra_defaults2d.xml und geogebra_defaults3d.xml löschen

1.4 Schliessen Zip und die Dateiendung von 01-22 allenfalls wieder auf .ggb umbenennen

Anstelle der Punkte 1.1 bis 1.4 kannst Du 01-22 aus diesem Post herunterladen

.

2. Löschen Roaming/Geogebra 5.0

  • Delete this folder: C:\Users\<username>\AppData\Roaming\GeoGebra 5.0
  • This is a hidden folder, so can be hard to find. One way is to press <Windows>R and then copy and paste this (changing <username> to your Windows username)
  • explorer /n, /e, /select, C:\Users\<username>\AppData\Roaming\GeoGebra 5.0
  • then right-click -> Delete

.

3. Roaming/Geogebra 5.0 neu erstellen

3.1 Ein leeres, neues GGB-Arbeitsblatt öffen

3.2 Schliessen ohne zurückschreiben

3.3 Kontrolle ob nun Roaming/Geogebra 5.0 vorhanden ist

.

4. unverseuchte Version 01-22 mit Defaultwerten ergänzen

4.1 01-22 öffen (der Fehler sollte nicht vorhanden sein!!)

4.2 Eine Kleinigen ändern und wieder zurück ändern (zB Beschriftung Anzeigen A_3)

4.3 01-22 schliessen und Speichern mit ja beantworten.

.

Ab jetzt sollte GGB wieder funktionieren,

  • sofern Du nicht irgend eine verseuchte Datei öffnest
  • oder Menu/Datei/SpeichernUnter verwendest (stattdessen System-Tools verwenden. Z.B: Kopieren, KopieSpeichern und Umbenennenvon Microsoft)

photo
1

rami,

zuerst ein herzliches Dankeschön für deine Hilfsbereitschaft und guten Erklärungen!


Meine Schritte waren:

zu 1. Erstellen einer unverseuchten Version

Zuerst:

  • Gesamten PC mittels eset NOD32 ANTIVIRUS auf Viren geprüft. ->Alles i.O.
  • WinZIP 22.0 von c/net heruntergeladen, Verwendung -> "Testversion benutzen"

1.1 Meine Datei kopiert, Kopie gespeichert und umbenannt von Microsoft, siehe Dateianlage

1.2 -1.4 erledigt, Datei 01-22 in ZIP "gespeichert"


zu 2. Löschen Roaming/Geogebra 5.0

in C:\Users\Peter\AppData\Roaming: GeoGebra 5.0 gelöscht, (GeoGebra nicht gelöscht!)


zu 3. Roaming/Geogebra 5.0 neu erstellen

3.1 Ein leeres, neues GGB-Arbeitsblatt geöffnet

3.2 über Datei/Schließen geschlossen -> 3.3 Roaming/Geogebra 5.0 nicht vorhanden!

3.2 über "X" geschlossen -> 3.3 Roaming/Geogebra 5.0 nicht vorhanden!


zu 4. unverseuchte Version 01-22 mit Defaultwerten ergänzen

4.1 Datei 01-22 geöffnet Fehler ist noch vorhanden!


Außerdem:

Die gepostete Datei heruntergeladen und umbenannt von Microsoft in 01-22-rami-Eck-Quadratrix.

Darin sind bereits von dir in der Zip-Dateiliste: geogebra_defaults2d.xml und geogebra_defaults3d.xml gelöscht.

4.1 01-22-rami-Eck-Quadratrix geöffnet: Fehler ist vorhanden! Siehe Dateianlage


Frage: Kann dieser Fehler vielleicht auch durch eine Software-Änderung behoben werden?

Gruß Petrus3743




photo
photo
1

Nachtrag:

Zwei Dateien in Dateianlage als Info.

  • In einer ist der Punkt als Name mit Index und in der anderen ist die der Punkt als Beschriftung mit Index.
  • Die Datei 01-Geogebra o. Fehler -Index in Beschriftung ist ein neues Arbeitsblatt.
  • Die Datei 01-GeoGebra m. Fehler - Index im Namen ist die "alte Datei" 01-22-rami-Eck-Quadratrix.
  • In beiden Dateien wurden nachträglich in der Zip-Dateiliste: geogebra_defaults2d.xml und geogebra_defaults3d.xml gelöscht.


photo
1

Zitat: "3.2 über Datei/Schließen geschlossen -> 3.3 Roaming/Geogebra 5.0 nicht vorhanden"

Da sehe ich zwei Fehlermöglichkeiten:

A) Die Bibliotheken sind ausgeblendet und der Dateimanager zeigt Dir nicht die effektive Sitation

B.) Deine GGB-Installation verwendet einen andern Pfad um den Ordner "GeoGebra 5.0" anzulegen und zu verwenden.

.

A1 Verändere die Einstellungen im Dateimanager (Anzeigen versteckte Dateien)

Dateimanager öffnen

Menu Ansicht / Optionen / Ordner und Suchoptionen /Ansicht

  • Geschütze Systemdateien ausblenden -> OFF
  • auswählen: Ausgeblendete Dateien und Ordner und Laufwerke anzeigen

Menu Ansicht / Optionen / Ordner und Suchoptionen /Suchen

  • Systemverzeichnisse einbeziehen -> ON
  • Komprimierte Dateien einbeziehen -> ON

B1 überprüfe (mit Dateimanager) ob der Ordner "C:\Users\Peter\AppData\Roaming\GeoGebra 5.0" oder "C:\Benutzer\Peter\AppData\Roaming\GeoGebra 5.0"vorhanden ist

Wenn ja: löschen und meine Checkliste nochmals abarbeiten

B2 Suchen GeoGebra 5.0 mit Dateimanager (Wenn in B1 nicht vorhanden)

Innerhalb "Benutzer" und, falls vorhanden "Users" manuell nachschauen ob bei den verschiedenen Benutzern resp User "AppData\Roaming\GeoGebra 5.0" vorhanden ist. Falls ja löschen und meine Checkliste nochmals abarbeiten

----------------------------------------

Bevor Du den Ordner "Geogebra 5.0" nicht gefunden, gelöscht und neu erstellst hast sind alle andern Aktionen obsolet, auch eine allfällige Bug-Meldung.

Viel Glück.

photo
1

Pardon, da habe ich mich vielleicht missverständlich ausgedrückt:


zu 2. Löschen Roaming/GeoGebra 5.0


  • Mein Betriebssystem ist Windows 10


  • den betreffenden Ordner im Dateiexplorer C:\Users\Peter\AppData\Roaming: GeoGebra 5.0 habe ich gefunden (lt. Liste in Englisch): Mittels "Windows-Taste + R-Taste gedrückt" öffnete sich das Fenster "Ausführen", den kopierten Pfad eingefügt und schließlich in C:\Users\Peter\AppData\Roaming den Ordner GeoGebra 5.0 gelöscht siehe Dateien "Dateiexplorer vorher" und "Dateiexplorer nachher"


Das Problem, das ich habe:

zu 3. Roaming/GeoGebra 5.0 neu erstellen


3.1 Ein leeres, neues GGB-Arbeitsblatt geöffnet ohne etwas einzutragen


3.2 über Datei/Schließen geschlossen oder über "X" geschlossen


3.3 erzeugt jeweils in meinem Dateiexplorer keinen neuen Ordner Roaming/GeoGebra 5.0! ->Dateiexplorer bleibt unverändert


  • Ändere ich eine GGB-Datei, erst dann wird ein neuer Ordner Roaming/GeoGebra 5.0! generiert! Siehe Datei "Dateiexplorer nach Änderung Datei"

Gruß Petrus3743

photo
photo
1

Ich empfehle Dir nur noch mit dem Dateiexplorer zu arbeiten also ohne "Windows-Taste + R"

Damit kannst Du auch löschen (markieren Del-Taste).

Wie GeoGebra 5.0 erzeugt wird, ist letzlich unbedeutend. Wichtig ist, dass keine potentiell verseuchten Dateien beteiligt sind.

Ich frage mich was der Ordner "Geogebra" bedeutet und wie der entstanden ist.

Aber eigentlich bin ich am Ende meines Lateins.

----------------------------------------------------

Als Vorbereitung für eine Bug-Meldung wären noch folgende Aktionen interessant

Löschen von Ordner "GeoGebra 5.0", Geogebra deinstallieren, Neuinstallation GGB 5

Kontrolle ob Ordner "GeoGebra 5.0" vorhanden

Neue Datei mit leerem Arbeitsblatt und einem Objekt (zB ein Punkt) erstellen und speichern.

Testen (ohne speichern) mit Anhang aus diesem Post (Defaultwerte gelöscht)

Testen (ohne speichern) mit einer vorhergehenden Version (verseucht)

Erneutes Testen (ohne Speichern) mit Anhang aus diesem Post

------------------------

Bug-Meldung erstellen

Das Problem sehr kurz beschreiben, mit Screen-Shot dokumentieren

Nicht vergessen: Systemumgebung, GGB-Version

Kurz und knapp: Beschreibung Test-Prozedere, Resultat und Anhänge der beteiligten Dateien.

Link zu diesem Tread.

photo
1

Please try the new version (v489) for the <sub><font size="-1>1</font></sub> problem

photo
1

Ich habe seit 31.08.2018 die Version (v489) in Windows 10 installiert. Die Dateien mit Fehler z.B. <sub> <font size = "- 1> 1 </ font> </ sub> habe ich schon länger, aber auch noch mit der aktuellen Version (v489). Siehe hierzu die Dateianlagen.

Der Fehler zeigt sich bei Bezeichnungen der Punkte mit Index z. B. A_1 in "Bearbeiten/Eigenschaften/ Namen", ab nicht in Bearbeiten/Eigenschaften/Beschriftung.

photo
1

Nachtrag

Am 03.09.2018 nochmals zuerst GeoGebra 5.0 gelöscht anschließend die Version (v489) neu installiert.

Ergebnis mit Datei 01-Testdatei-mit-5-Punkten: ohne Fehler!

Die zuletzt geposteten Dateien bleiben aber mit dem Fehler!

Frage: Kann man die (vielen) fehlerhaften Dateien reparieren?


photo
1

in der Zip-Dateiliste des GGB-Files geogebra_defaults2d.xml und geogebra_defaults3d.xml löschen

photo
1

Danke rami,

habe jetzt die GGB-Files geogebra_defaults2d.xml und geogebra_defaults3d.xml der folgenden Dateien gelöscht, dabei hat sich aber nichts verändert! Fehlerfreie Datei bleibt fehlerfrei, Dateien mit Fehler bleiben mit Fehler.


Übrigens:

Vor dem Speichen der neuen Version am 03.09.2018 (v489) habe ich auch den Ordner in Roaming "GeoGebra", der auch dir aufgefallen ist, gelöscht.

Die Datei 01-Testdatei-mit-5-Punkten-XXX wurde aus der Datei 01-Testdatei-mit-5-Punkten durch Menu/Datei/Speichern unter... generiert, aber sie blieb trotzdem fehlefrei!

photo
1

Es gibt viele Fehler in GGB, aber dieser scheint besonders mysteriös zu sein.

Lasst uns alle hoffen, dass ein findiger Programmierer auch mit diesem Fehler fertig wird (natürlich ohne gleich 2 neue einzubauen!!).

------------------------------

Versuche auch "Menü / Optionen / Standard Einstellungen wieder herstelen"

Wenn das nichts nützt frage Dich mal, warum Du eigentlich auf alte Dateien zurückgreifen must.

photo
1

Ja, "Menü / Optionen / Standard Einstellungen wieder herstellen" mit anschließendem Speichern, habe ich probiert. Nach einem erneuten Öffnen ist der Fehler wieder da!


Manche Konstruktionen, z. B. zu Vielecken, sind sehr ähnlich. Ich nehme eine vorhandene Datei, lösche die nicht relevanten Schritte und kann mit wesentlich weniger fortgesetzten Schritten die gewünschte Konstruktion erstellen.


Also nochmals herzlichen Dank für deine geduldige Hilfestellung. Gruß Petrus3743

photo
photo
1

@ Michael Borcherds

leider ist mein Problem wieder aufgetreten! Nachdem ich ein neues Arbeitsblatt begonnen hatte und anfangs, in der Konstruktion 01-21-Eck-Seitenlänge, der Index in "Bearbeiten/Eigenschaften" beim Ändern des "Namen"s, wie z. B. A_1, eine Zeit lang keine fehlerhaften Anzeigen generierte, war plötzlich, ich kann nicht sagen warum, das alte Problem wieder vorhanden! Was mache ich da nicht richtig? Mein Vorschlag, bitte versuche einmal selbst die in der Dateianlage angefügte Konstruktion auf einem neuen Arbeitsblatt zu konstruieren. Das Ergebnis wäre für mich sicher sehr hilfreich...

Gruß Petrus3743

photo
1

Frage: Ist das davor beschriebene Problem ein Bug bzw. kann es gelöst werden?

© 2020 International GeoGebra Institute