Download old version of GeoGebra 5 (Linux/deb)

s_o shared this question 8 months ago
Answered

Hey,

unfortunately an update broke my file (is attached, can it be fixed in a future version or did I use an feature that was removed?), it worked at the beginning of February, but not anymore. The oldest version I could find on the server is 5.0.524 (build 667890). I need 5.0.523 or older, there are 3rd-party sites that hosts old windows versions, and with 5.0.523 it works (it was also last modified with that version).

Best regards

Stefan

Comments (6)

photo
1

Please post a screenshot to show what's not working. If it's a regression we should fix it for a future release.

photo
1

Unfortunately the link you gave me does not contain any deb package.

Are you sure it works? It does not work with 5.0.527 on Linux. There have to be arcs (straight lines in Poincaré disk/hyperbolic geometry) between the points, they are missing because something is not defined it says in the Algebraic view.


Best regards

Stefan

photo
1

Here are two screenshots with the algebraic view on the left enabled. You can see a lot of things are undefined. With 5.0.523 it works fine and nothing is undefined.

photo
1

We've fixed the bug for next release (v528) (hopefully later this week)

photo
1

I'm sorry, but I'm confused now, I got an email notification with this content:

Sorry, it's a bug in saving (which goes back further than v523) so you'll need to use the attached file and wait for the next release (v528) - later this week hopefully


So, does that mean v523 stored the construction somehow wrong? Does v528 fixes that now automatically and therefore a modified file is not needed anymore? Or do I have to manually correct the XML construction data?

photo
1

Sorry, that was wrong (post was edited). Please try v529 online now

© 2019 International GeoGebra Institute