disappearing details of object in 3D view

Balint Hera shared this question 1 year ago
Answered

Hi Everyone!


To summarize the situation, my geogebra window looks like it has a V shaped white mask in the 3D graphic window around the two bottom corners (and sometimes at the top, too). When an object spreads the whole window, this mask "covers" it particularly, so that the "covered" field can't be seen. However, when rotating the object (with that same zoom parameter given before), the disappeared parts move with, like they were part of the object, not the window.


Please see the attached screens.


Have anybody ever experienced similar things? How to solve?


Thanks a lot!

Balint


b204ce8193554b8d3e487c479acc1b8b8fd1aff74c73580695a2cdbc8c66971eb5848241369e3bbbfd2b56be7c73771d16e28cede83b3dcbed8befcaf503f690

Comments (20)

photo
1

Please post your file.


Have you tried turning clipping off?

photo
1

Dear Michael,


I would like to ask you to set my question again as one which "need answer". As for me, none of the comments gave a solution for the problem.


Thank you in advance.


Cheers,

Balint

photo
photo
1

Both "Use clipping" and "Show clipping" were non-selected.


See file in the attachment.


Thank you!

photo
2

I am not sure what you want. But I just moved the 3d graph and now it shows the object all the time. See file attached.

Cheers

photo
1

Getting opened your file on my computer, when increasing the parameter p, the cube's bottom cornerr would be as bitten as to see on the printscreens above. Isn't that the same on your PC? (If not, the failure might be in my configuration, probably memory or graphic card.)


Cheers

photo
2

Do you mean the are within the red circle?9c28fc16da3054e0f79689e99804da23

photo
1

On one hand, yes. And I have more lines disappeared in the signed areas of the attached picture..

photo
2

Oh, I see. That happens because the limits of the 3d view. If you translate your cube to the center you may get a better visualisation of it. The missing parts of the cube are not visible because the actual 3d is not too big. You need to have a very big screen to show the big picture.

photo
1

I dont think so. Any clipping options are non-selected and the built-in 3D capacities of Geogebra must be more developed. On the picture attached you can see the center of my coordinate system arranged at a corner of the cube.

photo
1

I understand your point. I can move the 3d perspective and get the same kind of pics you have. I believe the reason is because your cube is defined at the bottom of the xy plane in the negative part of z-axis.


fb3ef25ca77844afef7c3f5d3e3f63ee

photo
1

Please notice the screenshots attached. I have two cubes, one above the z=0 plane, and another below. I can zoom the cubes arbitrarily, but they do not dissapear. Therefore I suspect that the above mentioned effect is a failure of Geogebra or my PC.

photo
photo
1

Do you mean, that a flawless and perfectly scaleable graphic representation is proven only if i define my poly ABOVE the z=0 plane?

photo
1

It does not matter where you put the cube in the space. You will always have a little piece of the big cube missing. See file attached. or here is the link for the worksheet

https://ggbm.at/D3DjDsd2

Regards.

photo
1

Thank you for your file. I checked it, and I experienced the same misterious disappearing and interesting graphic effect (a triangle). I think these are similar to those I have on my stripped cube. What do you think, is that a software bug, or do I have to revise my graphic card or other hardware configuration?


Thank you for your answer in advance!


Regards.

photo
1

I don't think it is your computer.


Kind regards.

photo
photo
1

a button with centerview[] comand can help

photo
1

Unfortunately, the way I applied that command with a button (CenterView [P1_1], where P1_1 is the corner originally coupled to the (0,0) point of my WCS), does nothing with the disappearing parts. Could you please give a detailed instuction how you would use that?

By the way, my problem is not that a certain point runs out of the window. Actually there are disappearing points and lines in the visible field.

photo
photo
1

This looks to me like clipping. Go to the graphics preferences for the 3D view. In the Basic tab (scroll down) there are options to use and or show clipping and about what size box to clip to. If you show the clipping and change the size of the clipping box and I think you'll see that parts of your cube disappear because they go outside the viewable box.

photo
1

I checked that options again. Non of them are selected. When I select "use clipping", my cube will be cutted with lines parallel to the edges of the cube. (In that case, when choosing "large" for "clipping box size", the original cube will be clipped to a much smaller one than those on the screenshots previously posted.)

photo
photo
1

Hi,

Your issue is not due to your computer nor GeoGebra. This deals with 3D view frustum: you can find some explanations here: https://en.wikipedia.org/wi...

The frustum corresponds to parts that are actually rendered on the 3D view. On this picture https://en.wikipedia.org/wi..., you can see left/right and top/bottom faces of the frustum (right in green and top in red) and near/far faces (near in yellow). Left, right, top and bottom exactly corresponds to the left, right, top and bottom edges of the 3D window on your screen, so parts that are e.g. too much on the left are not rendered and you don't notice it because it's outside of the view. Near/far faces are also needed for the following reason: to solve your issue, one would use a very away far plane, so all parts of your cube would be inside the frustum. Then the drawback would be to have bad sampled depth values for rendered pixels: that means that some pixels could be rendered above some others, because checking which one should be on top would not be accurate enough -- so some hidden parts could be visible. So depth checking correct we need a good balance between a big frustum and a good accuracy for depth calculations.

To solve your problem you need to center the view so it fits the best what you want to show. If you want to show all the cube, right-click > show all objects is the best. Then you can still zoom on some parts: it will keep this part at the same position, but then some other parts may go out of the frustum.

All the best,

Mathieu

© 2018 International GeoGebra Institute