DataFunction(<List of Points>)

Alexander Perl shared this idea 2 months ago
Declined

Currently, DataFunction only accepts input in the form

  • DataFunction(<List of Numbers>,<List of Numbers>)

Especially when working with tables of values, it seems a lot more practical to work with Lists of Points.


I want to suggest adding the following input option:

  • DataFunction(<List of Points>)

Comments (8)

photo
1

Sorry, we won't be adding that

photo
1

datafunction(x(list),y(list))


datafunction is not dynamic. you must add a script to list for update

photo
1

Yes, I know the workaround DataFunction(x(list),y(list)).


I just wonder: Why not simply implement DataFunction(list) by internally redirecting it to DataFunction(x(list),y(list))? There is no current meaning of DataFunction(list), so it wouldn't even collide with any previous meaning. It seems like a very simple and uncomplicated improvement to me, and I can see no reason why not to add it like that

photo
1

datafunction() se mantiene solo por consistencia con trabajos de una version antigua. En realidad datafunction() debió/pudo ser eliminada por los diseñadores

photo
1

And what makes you think so? What is the current recommended way to create a piecewise linear function given via value pairs?

photo
2

Wow, that has got to be the most complicated, confusing and user-unfriendly way to implement the simple task of allowing the creation of a piecewise linear function by given points.


Thanks for nothing.

photo
1

Only for your pleasure: one more (DataFunction() with points and no script needed when dynamic using)

Very difficult to read, but not so difficult to understand.

(but... it's possible to create a user-tool with this principle with n points in a list)

For my part, I prefer too an advanced DataFunction() with points and no scripts for dynamic use.

photo
© 2019 International GeoGebra Institute