Crash de Géogébra en affichage 3D avec une CG

Idriss Assemlal shared this question 7 months ago
Answered

Bonjour à tous,

Je crée ce sujet afin de demander de l'aide car après différentes recherches à travers internet et les forums de Géogébra, je n'ai trouvé aucune réponse convaincante.

Pré-requis:

- XPS 15" 9570 (GTX 1050)

- Dernière version de Géogébra 5 classique installée et ré-installée

- "c:\\Program Files (x86)\geogebra 5.0\jre\bin\javaw.exe" Voici l'executable relatif à la fonction 3D, dont j'ai demandé à ce qu'elle soit prise en compte par ma GX 1050


Voici mon problème:

Quand j'utilise Géogébra en 2D, le logiciel utilise mon processeur en tant que calculateur principal. Cependant, une fois un affichage en 3D demandé, j'ai remarqué que le logiciel devenait lent. Petit tour sur le gestionnaire des tâches: Processeur à 99% et GPU 0 (Donc chipset graphique de mon processeur) à fond.

Je décide donc d'aller voir dans le panneau de configuration NVidia afin de "forcer Géogébra" à utiliser ma carte graphique, à savoir une GTX 1050. Aucun problème pendant un long moment; le tout fonctionne au poil et je suis satisfait.

Cependant, depuis une semaine, dès que j'essaie de passer en affichage 3D ou de lancer un ficher ".ggb" qui requiert cette 3D, la fenêtre "Géogébra" s'affiche mais crash en plein milieu. Premier réflexe: je vérifie que mes pilotes graphiques sont à jour. Ils ne l'étaient pas et m'exécute donc. Ca ne résout pas le problème (même après deux installations). Je fais donc en sorte de désinstaller et installer de nouveau proprement Géogébra. Rien n'y fait.


Ainsi, je décide d'enlever le fait que Géogébra se lance avec ma carte graphique. Bingo: l'affichage 3D fonctionne avec mon processeur. Mais retour à la case départ, le logiciel devient lent et inutilisable.


Tentatives de résolution:

- MAJ des pilotes graphiques

- Installation de la dernière version de Géogébra

- Compatibilité en W95 et exécution en adminstrateur

- Installation de la dernière version de java


Des idées pour résoudre mon souci ?


Merci d'avance à tous !

Comments (3)

photo
1

I think that your notebook is no doubt powerful enough to run ggb.

The problem is with Windows, that at every update rolls out its own graphics card drivers, that are usually older and more full of bugs than the ones deployed by the producer of the graphics card.

And Windows new policies are so awful that if you update your drivers with the ones of the producers, at next Start, Windows replaces them with its own, unless you tweak the system a bit.

I've struggled with this and the proprietary drivers of my laptop manufacturer (yes, there is also this issue, many manufacturers have their own versions of card drivers, and don't allow you to install the card producer ones, unless - again, you tweak the system) for a long time, especially last year with the huge win 10 Fall Update.

In the end now my drivers are quite ok, despite both the inbuilt chip and the extra NVIDIA card already have updated drivers available on Intel/Nvidia sites - but the OS and Acer don't allow me to install them - and I currently don't want to tweak the OS.


But I understand that I was lucky with this. Probably this is not the case with you, despite your laptop looks much better than mine.

GeoGebra v.6, uses a different 3D rendering method with respect to v.5, and v.6 usually doesn't have those drivers issues of v.5. So I'm suggesting you to use v.6, that should work fine even with the inbuilt chip.

If you prefer to use v.5, you should try to downgrade your graphics drivers until you find one that works - or on the opposite, use the beta drivers available on the producer site and see if the issue is solved.


Sorry for being long winded, I've just told you my experience.

photo
1

Bonjour,

merci pour tout ! Je ne suis pas capable de comprendre les réponses ou suggestions que je lis...

Depuis septembre (peut-être avant), il m'est impossible d'utiliser geogebra 3D, je pense avoir téléchargé la dernière version à ce moment-là.


Depuis, plus d'axes, des choses bizarres dans la fenêtre 3D... Aujourd'hui, j'essaye de trouver une solution car je dois préparer avec la version 5.

J'ai désinstallé ...et réinstallé, c'est même pire !

Est-ce que java pourrait être en cause ?


D'après ce que j'ai lu, ma carte graphique pourrait poser problème ?

J'ai l'impression que peu de collègues (prof de math) sont concernés, je suis désolée de poser une question sans doute basique ! Amitiés et bonne soirée !

Joal

photo
1

Bonjour,

Ce n'est pas très satisfaisant mais la solution la plus simple (sans tripatouiller les subtilités de configuration windows / carte graphique) est d'utiliser la version 6 que tu peux installer hors ligne : https://www.geogebra.org/download

Mathieu

© 2019 International GeoGebra Institute