controle deslisante não funciona

marcoantonio shared this question 7 years ago
Answered

Olá forum,

Recentemente construí um mini-aplicativo no Geogebra, que trabalha com 3 controles deslisantes animados. Funciona perfeitamente bem no ambiente do Geogebra, mas quando o exporto como html para uma página da Web, nenhum dos controles deslisantes funciona. Fiquei muito decepcionado diante dessa impossibilidade de funcionamento.

Alguém já se deparou com o mesmo problema? Tem como solucioná-lo?

Experimentei em diversas versões do Geogebra, mas em nenhuma delas ele funcionou.

Muito agradecido pela ajuda.

Marco Antônio

Comments (3)

photo
1

Olá forum,

Recentemente construí um mini-aplicativo no Geogebra, que trabalha com 3 controles deslisantes animados. Funciona perfeitamente bem no ambiente do Geogebra, mas quando o exporto como html para uma página da Web, nenhum dos controles deslisantes funciona. Fiquei muito decepcionado diante dessa impossibilidade de funcionamento.

Alguém já se deparou com o mesmo problema? Tem como solucioná-lo?

Experimentei em diversas versões do Geogebra, mas em nenhuma delas ele funcionou.

Muito agradecido pela ajuda.

Marco Antônio


Será que a sua página html onde roda o programa, aceita o Java?

photo
1

Tá tudo certo com o Java.

O problema aparece quando se atribui ao controle deslisante uma velocidade dependente de alguma variável. Cada vez que essa velocidade muda, ele para de funcionar. Isso no arquivo html, pois no ggb funciona perfeitamente.

Resolvi esse problema com um botão externo na página, via Javascript, com o comando de ativar animações automáticas, mas acredito que exista uma solução melhor.

Abraços

photo
1

Resolvido! Bastou colocar

startAnimation() no código.

Para exportar para html, isso é necessário!

Abraços

© 2020 International GeoGebra Institute