cannot type input

Sofie Nielsen shared this problem 2 months ago
New

I have downloaded GeoGebra Classic 6 and I have this problem that when I change window I am not able to write input any longer (sometimes it happens in other situations also).


so: what can I do? I have tried to switch windows again and tried to click various other areas in GG, which only rarely helps

can I deactivate the keyboard on the screen? My computer (windows 10) is not touch, so I have no use for that keyboard

Comments (15)

photo
1

Do you mean input as in where you type equations at the bottom, or an input box? You may need to select "View" -> "Input" from the menu at the top. Then, it should at the input option.

photo
1

/a4pAYCyGEEEVQFjGmxIPEWAghhCiCsohxu3btrEqVKpEthaMxYyGEECJJxCPEIDEWQgghQkZiLIQQQoSMxFgIIYQIGYmxEEIIETISYyGEECJkJMZCCCFEyEiMhRBCiJCRGAshhBAhIzEWQgghQkZiLIQQQoSMxFgIIYQIGYmxEEIIETISYyGEECJkJMZCCCFEyEiMhRBCiJCRGAshhBAhIzEWQgghQkZiLIQQQoSMxFgIIYQIGYmxEEIIETISYyGEECJJHDt2zI4ePVpskRgLIYQQSQKhRZCLKxk5jshrhBBCCFEAZDI7O9uL5tatW61169aRPUWzadMm69ixo2VkZES2FI48YyGEECJJxCPEIDEWQgghQkZiLIQQQoSMxFgIIYQIGYmxEEIIETISYyGEECJkJMZCCCFEyEiMhRBCiJCRGAshhBAhIzEWQgghQkZiLIQQQoSMxFgIIYQIGYmxEEIIETISYyGEECJkJMZCCCFEyEiMhRBCiJCRGAshhBAhIzEWQgghQkZiLIQQQoSMxFgIIYQIGYmxEEIIETISYyGEECJJHDt2zI4ePVpskRgLIYQQSQKhRZCLKxk5jshrhBBCCFEAZDI7O9uL5tatW61169aRPUWzadMm69ixo2VkZES2FI48YyGEECJJxCPEIDEWQgghQkZiLIQQQoSK2f8PF8RTZFBXU3kAAAAASUVORK5CYII=

it is where I write almost everything. I think it is called the algebra window. I have tried to click twice and it helps but it is still causing problems. I'll try to record it in a video :)

photo
1

video showing my clicking like crazy:

https://youtu.be/72lsfAa8zoE

photo
1

I am having the exact same problem! Whenever i change tabs from geogebra, the program seems to stop taking any input from my keyboard, but the "in-program" keyboard at the bottom of geogebra still works.

photo
1

Does the online version work in Chrome?

https://www.geogebra.org/graphing

photo
1

it works in the online version in chrome

photo
1

Sorry, we're not able to reproduce the bug so far.

photo
1

4 people have reported the same problem, but it is not a problem because you cannot reproduce it? I can tell you that I work on a windows computer, office 2016.

photo
1

This is the way I solve this bug.


When you switch back to GeoGebra from another application and you will see the text "Input..." when you do not click on the "algebra input", double click on the "Input" text area and you can input from your keyboard.

Here is some situation that cause this bug happen:

+ Single click the "algebra input" area.

+ Double click on the "algebra input" area but outside the "Input" text area (even double click on "..." after the "Input" text area will cause this bug).

photo
1

This happens very frequently on the 2 Windows PCs I've tried over the past 2 days -- Win 7 and Win 10. I can't get it to let me enter further Input without closing Geogebra and re-opening it.


It's strange in that when I click the input box, the cursor goes there and flashes as if it's ready for input, but it ignores keyboard input.


The solution above didn't work for me, unfortunately.

photo
1

Some time ago I reported a similar problem https://help.geogebra.org/t..., and it comes and go.

Maybe you get use to the virtual keyboard until it is eventually possible to reproduce de bug :)

Moreover,

I am using an external monitor connected to my laptop with desktop expanded. Don't know if it maters. Another aspect is that if I open for instance the CAS window I am able to use it's input line, but still not the algebra's window input line. I mean using the physical keyboard.

photo
1

This bug affects me as well. I use Windows 10 laptop and the latest version of Geogebra Classic desktop application (but i've catched the bug in web version too). After switching to another application and returning back to Geogebra input fields stops responding to keyboard input (while virtual keyboard continues to work).

photo
1

This happens to me every time I switch back and forth to another window on both my computers (Win 10, Geogebra Classic 6). I can bypass the problem for now by using the actual input bar (hidden by default now) or using virtual keyboard (not the best option) rather than in the algebra view.

photo
1

Hi, I assume you use Alt + Tab to leave the window? I did that and could reproduce the problem. The problem is that pressing alt switches the keyboard to "alt" mode, then some keystrokes are ignored. A workaround is to click into the input bar and press + release Alt. We will try to fix this soon.

photo
1

Please try the new version (v411)

© 2017 International GeoGebra Institute