Cannot interesect sphere and line in CAS in GeoGebra 5

johannesfr shared this question 7 months ago
Answered

I am using GeoGebra 5 in Norwegian, so hopefully this problem translates correctly:

When trying to find the intersection between a sphere and a circle in CAS, GeoGebra only responds with a question mark. The closest solution I can find is to ask for a numerical solution by giving a third argument. The tool named "intersect" works like a charm to give a graphical solution, but sometimes one of the obects may be defined by an unknown variable (e.g. radius is not given), and there is no way to solve graphically.


A similar problem in 2D, interection of circle and line, can be solved in CAS without problem.


I think the following user has the same problem:

https://help.geogebra.org/t...


The thing is: I know for a fact that this used to work with earlier versions, as I have demonstrated this exact solution to my students earlier (although I never tried with an object defined by an unknown variable). If there is a way to bring it back, please do, or if this functionality has been moved to another command, please let me know.


Best regards from Norway

Comments (1)

photo
1

As Michael Borcherds said in the other post, not all Intersect command arguments are supported in CAS view.

You can see which objects are supported in the autocomplete list shown when typing the Intersect command.

Use the command in Input bar to get the intersections.

© 2019 International GeoGebra Institute