Can't update text value in Chrome

tachyondecay shared this problem 6 years ago
Answered

I'm trying to create a text object that includes a command. I would like it to read:

    m=Slope[a]

where a is the name of a line.


I've got the object. When I go to the Properties Dialog, I can double-click on the a label in the box and change it to Slope[a]. This shows the correct slope in the preview.


When I click "OK" to save the changes, however, the text object reverts to what it was previously.


Even if I completely wipe out the value and replace it with static text it seems to revert.


I'm using Google Chrome Version 44.0.2403.107 m w/ Java 7 Update 71.

https://ggbm.at/1447707

Comments (2)

photo
1

Hi, I'm not sure to answer to your question because I use the last version : 5-0-136-0

Within the text window you can :

- write texts ! Here : I write : <the name> = < the definition>

- add the values of commands using : advanced > GeoGebra icon (or the button Objects), for example (empty box) and write the command inside the box. Here : the command : Slope[a]

https://ggbm.at/144770982602b6e1f0bb3da2f713cfb133c1d7b

photo
1

I appreciate the reply, miir.


The Chrome version is a bit different. I couldn't figure out how to change the value of an object in the text edit box. If I click or double-click on the box surrounding the object, there is no visual cue that I can edit the value of the object. So I assumed that wasn't working and closed the edit box:


b80bcc40a3918beb67d38335e4ce58e2


When I edited the text via the Properties dialog, double-clicking on the object gave me a small textarea I could type into:


dd4caf149b121b941493b824a9c1e3bf


However, when I made my changes in this box and saved them, the text box would always revert to its original value. :(


Since your post, I've tried again and discovered that even though there is no visual feedback, I actually can edit the value of an object in the text edit box. I just have to start typing. I didn't realize this! When I change a to Slope[a] this way, it works (as you can see I did in that first screenshot).


To be clear, I still think the behaviour I originally reported is a bug--because changes to the text object aren't saving if you edit through the Properties dialog. You just helped me figure out a workaround that solved my problem.

© 2022 International GeoGebra Institute