Campo di inserimento

Dante Servi shared this problem 6 months ago
New

Ho appena pubblicata la modifica di una mia attività (tra quelle che non hanno il problema della visibilità) dove ho messo dei "campi di inserimento" collegati a slider.

Due di questi sono collegati a slider angolo.

Sul mio computer funzionano tutti correttamente nel senso che digitando un nuovo valore, se è il caso, lo converte in angolo (visibile anche dal fatto che aggiunge automaticamente il cerchiolino alto).

Provando l'attività pubblicata mi sono accorto che non considera il valore inserito come angolo (si nota anche che non aggiunge il relativo simbolo).

Questo provoca un successivo malfunzionamento e l'unica possibilità è chiudere e riaprire l'attività.

In uno dei due campi di iserimento (valore angolo) ho provato ad aggiungere un inutile script all'aggiornamento, inutile perché non risolve il problema.

. Dante

Comments (3)

photo
1

Please post your .ggb file

photo
1

Ecco il file.

. Dante

photo
1

Mi è venuto il dubbio che il problema potesse derivare dal collegamento a volte lento.

Avendo notato che lavorando off line sul mio computer (dove il problema non si presenta) cancellando il contenuto del campo di inserimento automaticamente compare a destra del cursore il cerchietto alto (simbolo di grado) o provato on line dal mio smartphone a cancellare il contenuto del campo di inserimento ed ho provato ad aspettare che comparisse il famigerato simbolo di grado a destra del cursore.

Io credo di aver aspettato a sufficenza che questo potesse succedere, ma non è successo.

Quindi credo di poter dire che non è la connessione il motivo.

. Dante

photo
© 2020 International GeoGebra Institute