Build instructions are not up to date

Dieter Vanderfaeillie shared this problem 5 years ago
Not a Problem

According to dev.geogebra I should be able to build the GeoGebra desktop app from source. The instructions are a bit outdated though. I'm not experienced with Eclipse. (I have Netbeans experience though)

  • I installed the Eclipse Java IDE (4.7) (Oxygen edition) on my linux machine
  • Through the Eclipse Marketplace I've installed

    - GWT Eclipse plugin 3.3.0 (with GWT 2.8.1 SDK included)

    - Subeclipse

  • The Gradle Integration for Eclipse (4.4) 3.6.4.RELEASE does not exist (anymore). According to this link the Gradle Integration are fading out their plugin in favor of the default Cradle managment (Buildship). Through the Marketplace I have installed the Gradle IDE (Gradle IDE Pack 3.8.x+1.0.x). This seems to be the last version available, (called Gradle STS)
  • Loading the project through svn worked fine.
  • The next step (import of Gradle through the Gradle STS results in an error:

4152456f3da5e44afda62c71c5f965e7


I've added the log (log_gradle_STS)


  • Trying the Buildship options results in a succesfull gradle execution, but the project has a ton of build errors:

38f1d038eb278aed2880096929e8a73bI"ve added the errors in a log (error.log)

(Building using java-8-oracle on ubuntu 16.04)

Comments (5)

photo
1

Hi,


* there are two different gradle plugins, STS and Buildship. Please try using Buildship. Also make sure you are using the latest version (1.0.20; Eclipse Neon is shipped with 1.0.18 which has a critical bug)

* to make the eclipse errors go away you need to execute the eclipse task on all projects (actually running eclipse on the top lever project geogebra should do just that). That will compile the parser from JavaCC and set the classpath.


Hope this helps,

Zbynek

photo
1

I'm running the Buildship Gradle version 2.1.1.


This is what happens when I run the Gradle tasks:

32e97516e081125c527083dbeda05283


If any additional output is required to diagnose the issue, let me know.

photo
1

Please try running the task called "eclipse"; it should generate some eclipse settings that will prevent the errors you are getting (+ it recompiles the parser).


By the way why are you interested in building GeoGebra from source?

photo
1

Maybe he wants to be sure not to violate the license agreement if he uses the software to visualize somthing for his co-worker at a company. And the only way to be sure that this is ok is a written agreement or building from source without using the installer nor the online service. I'm sure there is no problem in using the Software in this way, but after reading the agreement im not so sure of that anymore ;).

photo
1

I posted different comments on this site about failing to compile the sources checked out from GitHub. The instructions for this in the GitHub README are by far too short. Personally I can contribute with this post by saying that, under Windows, the command

gradlew.bat :web:run

works for most of the branches including "master" and "dev" while I have seen command

gradlew.bat :desktop:run

to work only if you check out the branch "release". Furthermore I cannot find how to run without errors

gradlew.bat :web:compileGwt
that is the gateway to generate a non minified Javascript codebase. This Gradle task fails complaining about missing gwt compile class. Will post some more hints here as I found how to circumvent this. The exact references for the GitHub branches and commits are

master c70e025
release 26a935c

© 2022 International GeoGebra Institute