bug in \qquad

lcfactorization shared this problem 3 years ago
Solved

:smiley_cat:


Current version: the latest 5.0.148 for windows


Observations:


When I insert a "\qquad", the fraction formula right after it doubled in the instant preview box( after inserting into the ggb, it looks just the same as the live preview).


64a9ddfabee17a3501dceac1cadb5d49

5013b7523e5b2466d4cc4046877ab057


I tried to insert "\qquad" before the first line, the same issue occurred:

09f2d133791a663e51e79225fc2fc469


what is happening?

Comments (6)

photo
1

hi ,


I found the example

    x^2\qquad y^2

did not exactly describe the defect.


I tried it on the latest 5.0.149 for windows.

If I start a completely new Geogebra window, sample code

    x^2\qquad y^2

does not create the default preview:

bcddfa47e758d4b085c2423eeb09e95b


Then I type the following code and the preview seems OK:

    R^2=(R-H)^2+L^2\\

    \qquad \Rightarrow R=\frac{H^2+L^2}{2HL}

124b70345e475910d7b82dc9d01309a0


The unexpected preview occurs only when I restart geogebra in a completely new window and type my example code:

60e7e699c5656283821a155f1f01f45b


Then if you don't restart geogebra, such code

    x^2\qquad y^2

did not exactly describe the defect.


I tried it on the latest 5.0.149 for windows.

If I start a completely new Geogebra window, sample code

    x^2\qquad y^2

does not create the default preview:

[attachment=3]2015-9-12 8-18-49.png[/attachment]


Then I type the following code and the preview seems OK:

    R^2=(R-H)^2+L^2\\

    \qquad \Rightarrow R=\frac{H^2+L^2}{2HL}

[attachment=2]2015-9-12 8-21-45.png[/attachment]


The unexpected preview occurs only when I restart geogebra in a completely new window and type my example code:

[attachment=1]2015-9-12 8-24-32.png[/attachment]


Then if you don't restart geogebra, such code


    Even pasting this in to the Text Tool is OK

      R^2=(R-H)^2+L^2\\ \qquad \Rightarrow R=\frac{H^2+L^2}{2HL}


    Does that give the bug for you?

photo
1

Yes, the problem persists in my side even I changed into the latest 5.0.153 for windows. :smiley_cat:


I am not sure is this an OS related problem.


Note that: before copying and pasting the LaTeX code into the text box and check the LaTeX formula checkbox, shut down geogebra and then restart a completely new geogebra process is the key to reproduce the bug.


that is, use right operation order as I said in the above posts with figures, I can also avoid such issue to happen.


PS. Recently, I encoutered another weird issue on windows 7 only for geogebra program:


Geogebra would not run unless with administrator's privilege; other programs all work properly.

this happens first only in one of my laptop, then spreads like virus to another :smiley_cat:


Now I can't get the bug to happen at all!


Even pasting this in to the Text Tool is OK

    R^2=(R-H)^2+L^2\\ \qquad \Rightarrow R=\frac{H^2+L^2}{2HL}


Does that give the bug for you?

photo
1

Sorry about the delay, please try in 5.0.280.0

© 2019 International GeoGebra Institute