Aplet geogebry na platformie eXe - problem techniczny

jsz shared this question 8 years ago
Answered

Witam!

Mam problem, którego pewnie nie mają inni (co wynika z intensywnego,bezskutecznego poszukiwania rozwiązania w głębokich czeluściach intertnetu ) . Sprawa wygląda następująco usiłuję położyć aplet geogebry w eXe. Robię to w sposób identyczny, jak można wyczytać w tutorialach.

Jednak po wczytaniu pliku ggb, już jak mi sie kod osadzenia tego ggb w eXe wygeneruje, dostaję dziwny dla mnie komunikat: "The new java Plug-In requires recent version of the Firefox browser (Firefox 3 or later). Wersja eXe 1.04.1 (gdzieś pewnie z 2007 i nowszej u źródła nie widać). Geogebra

3.2.46.0 z 17.12.2010. Znalazłem na tym forum podobny problem, gdzie ktoś sugerował,żeby wymienić komponenty geogebry w aplikacji eXe, ale nie pomaga. Prosze o pomoc

Comments (1)

photo
1

Problem wynika z faktu, że obecne oprogramowanie Java wymaga Firefoxa w wersji od 3.0 wzwyż, natomiast eXe zatrzymało się na wykorzystaniu Firefoxa w wersji 2 i ileś tam i nie jest już rozwijane. Tym samym drogi eXe i GeoGebry się rozeszły. Niestety z winy eXe.

Jedynym sposobem obejścia tego jest stworzenie w eXe struktury strony (menu i zawartość stron bez apletów GeoGebry) i wyeksportować do strony internetowej. Następnie trzeba wyeksportować dynamiczne karty pracy. Potem w edytorze HTML-a wklejamy fragmenty zawierające aplet do stron stworzonych w eXe.

© 2019 International GeoGebra Institute